diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index f680097942382b0619382226a725e7c8a81f6226..9488872a2944ff207da51647e381ab3bb6c8601c 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -3,13 +3,14 @@
 # Maintainer: omni <omni+alpine@hack.org>
 pkgname=ocaml
 pkgver=4.14.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Main implementation of the Caml programming language"
 url="https://ocaml.org/"
 arch="all !riscv64" # hangs forever at final build step
 license="LGPL-2.1-or-later-WITH-linking-exception"
 depends="$pkgname-runtime=$pkgver-r$pkgrel gcc"
 makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev binutils-dev"
+checkdepends="parallel"
 subpackages="
 	$pkgname-doc
 	$pkgname-dev
@@ -40,9 +41,7 @@ build() {
 }
 
 check() {
-	make ocamlopt
-	make ocamltest
-	make tests
+	make -C testsuite parallel
 }
 
 package() {