From 85913d170b3bcb2bc297c1020433c2155baadf9b Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Tue, 23 May 2023 15:40:50 +0000
Subject: [PATCH] testing/electron: upgrade to 24.3.1

---
 testing/electron/APKBUILD | 38 ++++++++++++++++++++++----------------
 1 file changed, 22 insertions(+), 16 deletions(-)

diff --git a/testing/electron/APKBUILD b/testing/electron/APKBUILD
index a9a9f1f4ab3e..6e914657aec9 100644
--- a/testing/electron/APKBUILD
+++ b/testing/electron/APKBUILD
@@ -1,9 +1,9 @@
 # Maintainer: psykose <alice@ayaya.dev>
 pkgname=electron
-pkgver=24.3.0
+pkgver=24.3.1
 pkgrel=0
-_chromium=112.0.5615.165
-_depot_tools=967cf672ebaa1d593be1d24e732cb5d0ddcfef1b
+_chromium=112.0.5615.183
+_depot_tools=63d20c330ba3ba5f644ade9e50b22ef3be09c1b8
 pkgdesc="Electron cross-platform desktop toolkit"
 url="https://github.com/electron/electron"
 arch="aarch64 x86_64" # same as chromium
@@ -135,17 +135,23 @@ snapshot() {
 	export CHROMIUM_BUILDTOOLS_PATH="$srcdir/src/buildtools"
 	mkdir -p "$srcdir"
 	cd "$srcdir"
-	git clone --branch=$_chromium --depth=1 \
-		https://chromium.googlesource.com/chromium/src.git
-
-	git clone https://github.com/electron/electron.git
-
-	(
-		git clone --depth 1 -b main https://chromium.googlesource.com/chromium/tools/depot_tools.git
-		cd depot_tools
-		git fetch --depth 1 origin $_depot_tools
-		git checkout $_depot_tools
-	)
+	if ! [ -d src ]; then
+		git clone --branch=$_chromium --depth=1 \
+			https://chromium.googlesource.com/chromium/src.git
+	fi
+
+	if ! [ -d electron ]; then
+		git clone https://github.com/electron/electron.git
+	fi
+
+	if ! [ -d depot_tools ]; then
+		(
+			git clone --depth 1 -b main https://chromium.googlesource.com/chromium/tools/depot_tools.git
+			cd depot_tools
+			git fetch --depth 1 origin $_depot_tools
+			git checkout $_depot_tools
+		)
+	fi
 
 	export PATH="$PATH:$srcdir/depot_tools"
 
@@ -211,7 +217,7 @@ snapshot() {
 		--exclude-vcs \
 		$pkgname-$pkgver
 
-	zstd --ultra --long -22 -T0 -vv $pkgname-$pkgver.tar
+	zstd --auto-threads=logical --ultra --long -22 -T0 -vv $pkgname-$pkgver.tar
 }
 
 prepare() {
@@ -448,7 +454,7 @@ lang() {
 }
 
 sha512sums="
-6e8f5f56d8bf6aedd093ef6c5cf1c863a511e09f0ffd7ac83ef22edb4b6aff4f430f37401e29b08c7f2fae93857d273f408e32917c523415ef75ed0cea32ffe3  electron-24.3.0-2.tar.zst
+c92971930bce1863dc492e5938407ee1ba88b22120d402ff4799b612beef376a00257b9942ed74067d2133320309d30e55bbed586f377d4d7b77eb7be91e4bcd  electron-24.3.1-2.tar.zst
 f88adc643dacf7e7be1b9bb77ff2c172cd04de2a988d3cdca77313122ba3ea93e6781ee675f3d7daf337a2542c0cbf31ffb08413e9f85c287b3a5e950d7d8a31  chromium-VirtualCursor-standard-layout.patch
 29bb685e03356a77df5fd347cdf55194cc8b3265c421cc76e54d64edefc329dbcb052deb26b22e8f587ce68456876c071de1b7d258dd0fcc6ee66c875ec4a020  chromium-revert-drop-of-system-java.patch
 fa291e941076146d0edd5b96c088240a44a6e0aca3dfc744929655607182d2dc47e6c35ecb419f7c623fcf7f26dc3c4dd924dbf5ed10c3b986283f5ef2f72573  chromium-use-alpine-target.patch
-- 
GitLab