diff --git a/testing/fbp/APKBUILD b/testing/fbp/APKBUILD
index e4e0a3e3e9ed69de49b95b21834f6d56603507c2..0abbb3ff7f651654983da9963d39526e3a584048 100644
--- a/testing/fbp/APKBUILD
+++ b/testing/fbp/APKBUILD
@@ -3,7 +3,8 @@
 pkgname=fbp
 pkgver=0.5
 pkgrel=0
-arch="aarch64 x86_64" # Limited by zig's supported arches in alpine
+pkgrel=1
+arch="aarch64 x86_64" # Limited by zig aport
 url="https://git.sr.ht/~mil/fbp"
 pkgdesc="Framebuffer linux phone UI environment, supported best on the Pinephone"
 source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/fbp/archive/$pkgver.tar.gz"
@@ -11,8 +12,13 @@ license="GPL-3.0-or-later"
 makedepends="zig>=0.9.1 freetype-dev linux-headers"
 options="!check" # Has no tests
 
+# We may want other than "baseline" for other targets, when enabled by zig
+case "$CARCH" in
+	aarch64|x86_64) cputarget=baseline ;;
+esac
+
 build() {
-	zig build
+	zig build -Drelease-safe ${cputarget:+-Dcpu="$cputarget"}
 }
 
 package() {