From 822be86f3ee5cd2404afb04a8b6d73cda7c551ed Mon Sep 17 00:00:00 2001
From: Noel Kuntze <noel.kuntze@thermi.consulting>
Date: Fri, 14 Jun 2024 05:20:12 +0200
Subject: [PATCH] testing/grommunio-sync: fixes

- Fixed directories in config files
- Fixed user homedir
---
 testing/grommunio-sync/APKBUILD                   | 6 ++++--
 testing/grommunio-sync/grommunio-sync.pre-install | 2 +-
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/testing/grommunio-sync/APKBUILD b/testing/grommunio-sync/APKBUILD
index f6e045276b09..ea21214f11c5 100644
--- a/testing/grommunio-sync/APKBUILD
+++ b/testing/grommunio-sync/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Noel Kuntze <noel.kuntze@contauro.com>
 pkgname=grommunio-sync
 pkgver=2.0_git20240327
-pkgrel=2
+pkgrel=3
 pkgdesc="Exchange ActiveSync interface for grommunio"
 # s390x: blocked by grommunio-gromox
 arch="noarch !riscv64 !s390x"
@@ -51,11 +51,13 @@ package() {
 
 	# nginx conf
 	sed -i "s@/var/log/grommunio/@/var/log/nginx/@" build/grommunio-sync.conf
+	sed -i "s@/usr/share/grommunio-sync/@/usr/share/webapps/grommunio-sync/@" build/grommunio-sync.conf
 	install -Dpm644 build/grommunio-sync.conf "$pkgdir"/usr/share/grommunio-common/nginx/locations.d/grommunio-sync.conf
+	sed -i "s@/php-fpm/@/php-fpm${_php#php}/@" build/grommunio-sync-upstream.conf
 	install -Dpm644 build/grommunio-sync-upstream.conf "$pkgdir"/usr/share/grommunio-common/nginx/upstreams.d/grommunio-sync.conf
 
 	# php-fpm
-	sed -i "s@/php-fpm/@/php-fpm${_php##php}/@" build/pool-grommunio-sync.conf
+	sed -i "s@/php-fpm/@/php-fpm${_php#php}/@" build/pool-grommunio-sync.conf
 	install -Dpm644 build/pool-grommunio-sync.conf "$pkgdir"/etc/$_php/php-fpm.d/pool-grommunio-sync.conf
 
 	# logrotate
diff --git a/testing/grommunio-sync/grommunio-sync.pre-install b/testing/grommunio-sync/grommunio-sync.pre-install
index 1332c267f4e4..573af1d44dfc 100644
--- a/testing/grommunio-sync/grommunio-sync.pre-install
+++ b/testing/grommunio-sync/grommunio-sync.pre-install
@@ -1,6 +1,6 @@
 #!/bin/sh
 
 addgroup -S grosync 2>/dev/null
-adduser -S -D -H -h /usr/share/grommunio-sync -s /sbin/nologin -G grosync -g "Grommunio ActiveSync" grosync 2>/dev/null
+adduser -S -D -H -h /usr/share/webapps/grommunio-sync -s /sbin/nologin -G grosync -g "Grommunio ActiveSync" grosync 2>/dev/null
 
 exit 0
-- 
GitLab