diff --git a/testing/grommunio-sync/APKBUILD b/testing/grommunio-sync/APKBUILD
index f6e045276b094d33663cc3ddad65da501b83e78f..ea21214f11c518758f98350b4284b26bd40e8987 100644
--- a/testing/grommunio-sync/APKBUILD
+++ b/testing/grommunio-sync/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Noel Kuntze <noel.kuntze@contauro.com>
 pkgname=grommunio-sync
 pkgver=2.0_git20240327
-pkgrel=2
+pkgrel=3
 pkgdesc="Exchange ActiveSync interface for grommunio"
 # s390x: blocked by grommunio-gromox
 arch="noarch !riscv64 !s390x"
@@ -51,11 +51,13 @@ package() {
 
 	# nginx conf
 	sed -i "s@/var/log/grommunio/@/var/log/nginx/@" build/grommunio-sync.conf
+	sed -i "s@/usr/share/grommunio-sync/@/usr/share/webapps/grommunio-sync/@" build/grommunio-sync.conf
 	install -Dpm644 build/grommunio-sync.conf "$pkgdir"/usr/share/grommunio-common/nginx/locations.d/grommunio-sync.conf
+	sed -i "s@/php-fpm/@/php-fpm${_php#php}/@" build/grommunio-sync-upstream.conf
 	install -Dpm644 build/grommunio-sync-upstream.conf "$pkgdir"/usr/share/grommunio-common/nginx/upstreams.d/grommunio-sync.conf
 
 	# php-fpm
-	sed -i "s@/php-fpm/@/php-fpm${_php##php}/@" build/pool-grommunio-sync.conf
+	sed -i "s@/php-fpm/@/php-fpm${_php#php}/@" build/pool-grommunio-sync.conf
 	install -Dpm644 build/pool-grommunio-sync.conf "$pkgdir"/etc/$_php/php-fpm.d/pool-grommunio-sync.conf
 
 	# logrotate
diff --git a/testing/grommunio-sync/grommunio-sync.pre-install b/testing/grommunio-sync/grommunio-sync.pre-install
index 1332c267f4e4cdcbefa037de19a5c4e02e63f1ec..573af1d44dfc8121c8f19132bb29697dcae8f2f9 100644
--- a/testing/grommunio-sync/grommunio-sync.pre-install
+++ b/testing/grommunio-sync/grommunio-sync.pre-install
@@ -1,6 +1,6 @@
 #!/bin/sh
 
 addgroup -S grosync 2>/dev/null
-adduser -S -D -H -h /usr/share/grommunio-sync -s /sbin/nologin -G grosync -g "Grommunio ActiveSync" grosync 2>/dev/null
+adduser -S -D -H -h /usr/share/webapps/grommunio-sync -s /sbin/nologin -G grosync -g "Grommunio ActiveSync" grosync 2>/dev/null
 
 exit 0