diff --git a/community/sphinx/APKBUILD b/community/sphinx/APKBUILD
index 2d7af1ddcbb0d76faee369bf339fca78b32802f2..6012be8083acf9a6401477117868f92dcab84bc8 100644
--- a/community/sphinx/APKBUILD
+++ b/community/sphinx/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
 pkgname=sphinx
 pkgver=2.2.11
-pkgrel=5
+pkgrel=6
 pkgdesc="Free open-source SQL full-text search engine"
 url="http://www.sphinxsearch.com"
 arch="all"
@@ -58,9 +58,8 @@ php() {
 	pkgdesc="PHP api for sphinx search engine"
 
 	mkdir -p "$subpkgdir"/usr/share/php/$pkgname/api
-	for i in $(ls $builddir/api/*.php); do
-		mv $i "$subpkgdir"/usr/share/php/$pkgname/api ;
-	done
+	find $builddir/api/ -type f -maxdepth 1 -name "*.php" \
+		-exec mv {} "$subpkgdir"/usr/share/php/$pkgname/api/ \;
 }