Commit 7ee3b493 authored by Natanael Copa's avatar Natanael Copa

main/libxklavier: upgrade to 5.3

parent edec2702
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxklavier
pkgver=5.2.1
pkgver=5.3
pkgrel=0
pkgdesc="High-level API for X Keyboard Extension"
url="http://gswitchit.sourceforge.net"
......@@ -10,7 +10,14 @@ subpackages="$pkgname-dev $pkgname-doc"
depends="xkeyboard-config iso-codes"
makedepends="pkgconfig libxkbfile-dev libxml2-dev glib-dev libxi-dev iso-codes
gettext-dev libiconv-dev"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
_v=$pkgver
case $pkgver in
*.*.*) _v=${pkgver%.*};;
*.*.*.*) _v=${pkgver%.*.*};;
esac
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${_v}/$pkgname-$pkgver.tar.xz"
depends_dev="libxml2-dev glib-dev gettext-dev libxkbfile-dev"
......@@ -28,4 +35,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la || return 1
}
md5sums="b3e718ee156d0d8883dfc3ff3bb86779 libxklavier-5.2.1.tar.xz"
md5sums="290ea2a8abc40f78a3a16bdae6f02808 libxklavier-5.3.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment