Commit 7e4cc01c authored by Natanael Copa's avatar Natanael Copa
Browse files

main/cups: upgrade to 1.6.1

parent 8d76e95d
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups
pkgver=1.5.4
pkgrel=1
pkgver=1.6.1
pkgrel=0
pkgdesc="The CUPS Printing System"
url="http://www.cups.org/"
arch="all"
license="GPL"
subpackages="$pkgname-dev $pkgname-doc libcups $pkgname-client $pkgname-lang"
makedepends="openssl-dev libpaper-dev dbus-dev jpeg-dev>=8 zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs ipptool $pkgname-client
$pkgname-lang"
depends_dev="openssl-dev zlib-dev"
makedepends="$depends_dev libpaper-dev dbus-dev jpeg-dev>=8"
depends="cups-client poppler-utils openssl dbus"
install="cups.pre-install"
pkggroups="lp lpadmin"
......@@ -18,7 +20,6 @@ source="ftp://ftp.easysw.com/pub/$pkgname/$pkgver/$pkgname-$pkgver-source.tar.bz
cupsd.initd
"
depends_dev="openssl-dev zlib-dev"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
......@@ -76,18 +77,28 @@ _mv() {
done
}
libcups() {
libs() {
pkgdesc="CUPS libraries"
depends=
replaces="libcups"
cd "$pkgdir"
_mv usr/lib/*.so*
install -d "$pkgdir"/etc/cups
}
ipptool() {
pkgdesc=""
depends=
cd "$pkgdir"
_mv usr/bin/ipptool \
usr/share/cups/ipptool
}
client() {
pkgdesc="CUPS client"
depends=
cd "$pkgdir"
_mv usr/bin \
usr/share/cups/charsets \
usr/sbin/accept \
usr/sbin/cupsaddsmb \
usr/sbin/cupsctl \
......@@ -100,6 +111,6 @@ client() {
usr/sbin/reject
}
md5sums="de3006e5cf1ee78a9c6145ce62c4e982 cups-1.5.4-source.tar.bz2
md5sums="87ade07e3d1efd03c9c3add949cf9c00 cups-1.6.1-source.tar.bz2
f861b18f4446c43918c8643dcbbd7f6d cups.logrotate
1154ed66fdcfa0523f929a369079f43c cupsd.initd"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment