diff --git a/testing/nushell/APKBUILD b/testing/nushell/APKBUILD
index 85c91e4426e6cebb190eaf3223933876ec1f23cc..9a3c6de16a946204fff67b521ba75d9c6d0439f9 100644
--- a/testing/nushell/APKBUILD
+++ b/testing/nushell/APKBUILD
@@ -2,11 +2,11 @@
 # Maintainer: nibon7 <nibon7@163.com>
 pkgname=nushell
 pkgver=0.72.0
-pkgrel=0
+pkgrel=1
 pkgdesc="A new type of shell"
 url="https://www.nushell.sh"
-# s390x/riscv64 rust/cargo
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le"
+# s390x: nix crate
+arch="all !s390x"
 license="MIT"
 makedepends="cargo openssl-dev>3 libx11-dev libxcb-dev libgit2-dev"
 checkdepends="bash"
@@ -20,6 +20,9 @@ export CARGO_PROFILE_RELEASE_LTO="fat"
 export CARGO_PROFILE_RELEASE_OPT_LEVEL="s"
 export CARGO_PROFILE_RELEASE_PANIC="abort"
 
+# Temporarily allow textrels on riscv64
+[ "$CARCH" = "riscv64" ] && options="$options textrels"
+
 prepare() {
 	default_prepare
 	cargo fetch --locked