diff --git a/community/heimdall/APKBUILD b/community/heimdall/APKBUILD
index aa622d1ca8a3b9f494951887ab9a81e094e5e578..16ded93f447925ea8202918425d881be40ae536c 100644
--- a/community/heimdall/APKBUILD
+++ b/community/heimdall/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Bart Ribbers <bribbers@disroot.org>
 # Maintainer: Henrik Grimler <henrik@grimler.se>
 pkgname=heimdall
-pkgver=2.0.2
+pkgver=2.1.0
 pkgrel=0
 pkgdesc="Free implementation of Samsung Galaxy devices flashing protocol"
 url="https://git.sr.ht/~grimler/Heimdall"
@@ -31,8 +31,8 @@ package() {
 }
 
 sha512sums="
-62849bfe7550214dd774efea65169673fa916f9d204000f793d995aed9def95fcc895c8913cd648f2397ab7fd154257e0394b78c180ed60d043c75858bac7c0a  heimdall-v2.0.2.tar.gz
+75c58cdfaa183e1a8a73127875f716cf168da3a109eefafc7bf1fe9573b9d716da23ff15d0df93474568a678a1b38e71611c745b688c3bc024e70672d921fdd6  heimdall-v2.1.0.tar.gz
 271098ddcead6b4d1edd76ac208099506d67a7640b40c68ea4d8a6a85b6fa464b6024371004b02f1a3c4bdfc38415cf63f2fde97099e52db72903227d653b9b8  heimdall_flash_kernel.sh
-ed6892ca86906473fcf84a4919396762e7a5639fdaf6360052764e1d522f52d6a1fd6137c9ebc3f5e096c489b8e8d38688740e96799a5426d87ed48bc68a9253  heimdall_flash_isorec_kernel.sh
-45e742bb3a8c8d0bc6806a4e9f860b04f255cad72a8602c04759178284c66e0a90d3ea22249b5fa69de1dd1d6ecd6221adaa63d611aa20d2a54aa20868e86a9f  heimdall_wait_for_device.sh
+ec050b4f594f750eb3e3a5f80304bd5e692f2b2cabf4cd18e44543f930dc1290a5bb6d58d6c0d3589fcea8c69b74df8c240bc8fabbeb92369bdc2dc36a20ffb7  heimdall_flash_isorec_kernel.sh
+e454a1c9d49177db0ae8adf55261f749ceca393d3800179db8b3591fff0b90e54448b3239e28e78dc67029406c29cba648b94764665d178b7fb53369ac58d937  heimdall_wait_for_device.sh
 "
diff --git a/community/heimdall/heimdall_flash_isorec_kernel.sh b/community/heimdall/heimdall_flash_isorec_kernel.sh
index b63cf325fb5c36508fc0c7b5998bd111c07a43a3..b365fbeede3ab7f912a0a36f8c80106c0ab3e772 100644
--- a/community/heimdall/heimdall_flash_isorec_kernel.sh
+++ b/community/heimdall/heimdall_flash_isorec_kernel.sh
@@ -29,6 +29,6 @@ echo "Flash initramfs to the '$INITFS_PARTITION' partition (isorec-style) and"
 echo "kernel to the '$KERNEL_PARTITION' partition"
 gunzip -c "$INITFS" | lzop > /tmp/initramfs.lzo
 cat "$KERNEL" "$DTB" > /tmp/vmlinuz-dtb
-heimdall flash --"$INITFS_PARTITION" /tmp/initramfs.lzo --"$KERNEL_PARTITION" /tmp/vmlinuz-dtb
+heimdall flash --wait --"$INITFS_PARTITION" /tmp/initramfs.lzo --"$KERNEL_PARTITION" /tmp/vmlinuz-dtb
 rm /tmp/initramfs.lzo
 rm /tmp/vmlinuz-dtb
diff --git a/community/heimdall/heimdall_wait_for_device.sh b/community/heimdall/heimdall_wait_for_device.sh
index 5904c10c86c9541c9fb410779922545c6dcf8327..5983304075abef12e6d199c6c38ac5211e6284cf 100644
--- a/community/heimdall/heimdall_wait_for_device.sh
+++ b/community/heimdall/heimdall_wait_for_device.sh
@@ -1,6 +1,9 @@
 #!/bin/sh
 # Simple wrapper, that makes heimdall behave more like fastboot
 
+echo "DEPRECATION WARNING: heimdall_wait_for_device.sh is deprecated and will"
+echo "be removed in a future version. Please use heimdall <action> --wait"
+echo "instead."
 echo "< wait for any device >"
 while ! heimdall detect > /dev/null 2>&1; do
 	sleep 1