From 7d54f82f931d14b47e4ee2af6b0734a03deb5658 Mon Sep 17 00:00:00 2001
From: Celeste <20312-Celeste@users.gitlab.alpinelinux.org>
Date: Mon, 29 Jan 2024 07:02:51 +0000
Subject: [PATCH] community/py3-pytest-snapshot: new aport

https://pypi.org/project/pytest-snapshot/
Plugin for snapshot testing with pytest

Needed as checkdepends for community/py3-awesomeversion 23.11.0
---
 community/py3-pytest-snapshot/APKBUILD | 38 ++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 community/py3-pytest-snapshot/APKBUILD

diff --git a/community/py3-pytest-snapshot/APKBUILD b/community/py3-pytest-snapshot/APKBUILD
new file mode 100644
index 000000000000..5ed5aedc5fb0
--- /dev/null
+++ b/community/py3-pytest-snapshot/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-pypi, template 4
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=py3-pytest-snapshot
+pkgver=0.9.0
+pkgrel=0
+#_pkgreal is used by apkbuild-pypi to find modules at PyPI
+_pkgreal=pytest-snapshot
+pkgdesc="Plugin for snapshot testing with pytest"
+url="https://pypi.org/project/pytest-snapshot/"
+arch="noarch"
+license="MIT"
+depends="py3-pytest"
+makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/pytest-snapshot/pytest-snapshot-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+	gpep517 build-wheel \
+		--wheel-dir .dist \
+		--output-fd 3 3>&1 >&2
+}
+
+check() {
+	python3 -m venv --clear --without-pip --system-site-packages .testenv
+	.testenv/bin/python3 -m installer .dist/*.whl
+	.testenv/bin/python3 -m pytest
+}
+
+package() {
+	python3 -m installer -d "$pkgdir" \
+		.dist/*.whl
+}
+
+sha512sums="
+ad0ce310ea8927dfac1ae07bae0bfb6651cfe4cb9e0ec17475923eaee4a64cac99ca24840da3831dfc24a514cde09cd9433fa896316646ba40078b46d8f079db  pytest-snapshot-0.9.0.tar.gz
+"
-- 
GitLab