diff --git a/testing/mapserver/20-libxml.patch b/testing/mapserver/20-libxml.patch
new file mode 100644
index 0000000000000000000000000000000000000000..b8d54c40754006dd1c74e011cede6919c7ef8c97
--- /dev/null
+++ b/testing/mapserver/20-libxml.patch
@@ -0,0 +1,50 @@
+From 2cea5a12a35b396800296cb1c3ea08eb00b29760 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Sat, 18 Nov 2023 22:13:46 +0100
+Subject: [PATCH] Fix compilation errors with libxml2 2.12
+
+---
+ mapows.c     | 2 +-
+ mapwcs.cpp   | 2 +-
+ mapwcs20.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mapows.c b/mapows.c
+index 734f432d3..6686ce3e4 100644
+--- a/mapows.c
++++ b/mapows.c
+@@ -168,7 +168,7 @@ static int msOWSPreParseRequest(cgiRequestObj *request,
+ #endif
+     if (ows_request->document == NULL
+         || (root = xmlDocGetRootElement(ows_request->document)) == NULL) {
+-      xmlErrorPtr error = xmlGetLastError();
++      const xmlError *error = xmlGetLastError();
+       msSetError(MS_OWSERR, "XML parsing error: %s",
+                  "msOWSPreParseRequest()", error->message);
+       return MS_FAILURE;
+diff --git a/mapwcs.cpp b/mapwcs.cpp
+index 5459f5bb1..817c8a784 100644
+--- a/mapwcs.cpp
++++ b/mapwcs.cpp
+@@ -362,7 +362,7 @@ static int msWCSParseRequest(cgiRequestObj *request, wcsParamsObj *params, mapOb
+     /* parse to DOM-Structure and get root element */
+     if((doc = xmlParseMemory(request->postrequest, strlen(request->postrequest)))
+         == NULL) {
+-      xmlErrorPtr error = xmlGetLastError();
++      const xmlError *error = xmlGetLastError();
+       msSetError(MS_WCSERR, "XML parsing error: %s",
+                  "msWCSParseRequest()", error->message);
+       return MS_FAILURE;
+diff --git a/mapwcs20.cpp b/mapwcs20.cpp
+index fd69e23e8..4c1f76083 100644
+--- a/mapwcs20.cpp
++++ b/mapwcs20.cpp
+@@ -1446,7 +1446,7 @@ int msWCSParseRequest20(mapObj *map,
+ 
+     /* parse to DOM-Structure and get root element */
+     if(doc == NULL) {
+-      xmlErrorPtr error = xmlGetLastError();
++      const xmlError *error = xmlGetLastError();
+       msSetError(MS_WCSERR, "XML parsing error: %s",
+                  "msWCSParseRequest20()", error->message);
+       return MS_FAILURE;
diff --git a/testing/mapserver/APKBUILD b/testing/mapserver/APKBUILD
index 70ad25fd488aa283e9f6f09ed815a920b9ffe777..1c579db8eecd24ee3838a75872d3a3e04d5867ea 100644
--- a/testing/mapserver/APKBUILD
+++ b/testing/mapserver/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Bjoern Schilberg <bjoern@intevation.de>
 pkgname=mapserver
 pkgver=8.0.1
-pkgrel=2
+pkgrel=3
 pkgdesc="CGI-based platform for publishing spatial data and interactive mapping applications to the web"
 url="https://mapserver.org/"
 # s390x: blocked by exempi-dev
@@ -38,6 +38,7 @@ subpackages="
 source="
 	https://download.osgeo.org/mapserver/mapserver-$pkgver.tar.gz
 	10-musl.patch
+	20-libxml.patch
 	"
 
 build() {
@@ -78,4 +79,5 @@ package() {
 sha512sums="
 dae14a7eb6b09f5461c19bff83ca8ed6c21ae84d451b2c854794efb25b144b7edbf2a33479dc53e78aa646e5196e81219b4a1f393ff824db4508204a2d0301d1  mapserver-8.0.1.tar.gz
 12743afabee45bc77788b699cfc8ac50cf11629e0041b7b9aac3ba1c966d14fa0280044b72ac1b7520e99124d9b4627a6b5d005a486ae9ad03bc86b0775ad547  10-musl.patch
+e48aeabe8e96b8fb20006672812441218c7b8ff7f765e03c36a5a6a1a8196b847df8d8d18b9164d090cf574a9c7226e4512686773345686be2f0b2819aa4a50a  20-libxml.patch
 "