diff --git a/community/py3-impacket/APKBUILD b/community/py3-impacket/APKBUILD
index 50b0a1eda88ab4770b8e5c83a3cb7587339df586..96d874f3cfd3862bf7e15e565bef01f303f332b6 100644
--- a/community/py3-impacket/APKBUILD
+++ b/community/py3-impacket/APKBUILD
@@ -2,8 +2,8 @@
 # Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
 pkgname=py3-impacket
 _pkgname=impacket
-pkgver=0.11.0
-pkgrel=1
+pkgver=0.12.0
+pkgrel=0
 pkgdesc="Collection of Python3 classes providing access to network packets"
 url="https://github.com/SecureAuthCorp/impacket"
 arch="noarch"
@@ -59,6 +59,6 @@ package() {
 }
 
 sha512sums="
-8bd7baf3c9c4ca826d9bd472bc1842e4fc1b0a9eae643f247606b05f4b375416550b9e4445414ec51e6524422666ce0c869ee63a2aef59451b827feaccb0db7b  impacket-0.11.0.tar.gz
-adf35684d0e6498c6b39edc5a19ee84065d4bd306c5a76565b650ace25fa754e0e505e15aee7a84ac872a29c6bf9c59ea8651a27d0b8cd0dbcb5694f44430c9a  version.patch
+48db5e2973cebc87a84118f2d83202f9583f45b4294e7b17c49da32bd6aedcf4e704447dd9d87e03f754c3947a9759a39624e44c5849718daae9e96b04f9aeb0  impacket-0.12.0.tar.gz
+cc3e4ab6de1cf5fdb548bc32da84bfda6284b43b0d01f67a65398dfaef0faf0ad03327ed31b5c3abd553e59c0accda9ef783043908fe23560461d4d4aff33627  version.patch
 "
diff --git a/community/py3-impacket/version.patch b/community/py3-impacket/version.patch
index 011e6dbec816d7ea5055a0ffd4b35060d936dba1..2c3034f43671b29d7776e2393d6283f33a542f43 100644
--- a/community/py3-impacket/version.patch
+++ b/community/py3-impacket/version.patch
@@ -1,8 +1,8 @@
 diff --git a/impacket/version.py b/impacket/version.py
-index 520d0a4..8889bdd 100644
+index 87a971b..0db53d1 100644
 --- a/impacket/version.py
 +++ b/impacket/version.py
-@@ -7,17 +7,11 @@
+@@ -9,17 +9,11 @@
  # for more information.
  #
  
@@ -17,8 +17,8 @@ index 520d0a4..8889bdd 100644
 -    version = "?"
 -    print("Cannot determine Impacket version. "
 -          "If running from source you should at least run \"python setup.py egg_info\"")
--BANNER = "Impacket v{} - Copyright 2023 Fortra\n".format(version)
-+BANNER = "Impacket v{} - Copyright 2023 Fortra\n".format(version('impacket'))
+-BANNER = "Impacket v{} - Copyright Fortra, LLC and its affiliated companies \n".format(version)
++BANNER = "Impacket v{} - Copyright Fortra, LLC and its affiliated companies \n".format(version('impacket'))
  WARNING_BANNER = "".join(("===============================================================================\n",
                            "  Warning: This functionality will be deprecated in the next Impacket version  \n", 
                            "===============================================================================\n"))