From 777f324f8f002aa86d0d4fd81eaeb404bd4c2216 Mon Sep 17 00:00:00 2001
From: Leo <thinkabit.ukim@gmail.com>
Date: Mon, 28 Sep 2020 00:46:24 -0300
Subject: [PATCH] testing/autotiling: upgrade to 1.1

---
 testing/autotiling/APKBUILD | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

diff --git a/testing/autotiling/APKBUILD b/testing/autotiling/APKBUILD
index 7a994f734d9d..9df3b9394faa 100644
--- a/testing/autotiling/APKBUILD
+++ b/testing/autotiling/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Matthew.T.Hoare <matthew.t.hoare@gmail.com>
 # Maintainer: Matthew.T.Hoare <matthew.t.hoare@gmail.com>
 pkgname=autotiling
-pkgver=1.0
+pkgver=1.1
 pkgrel=0
 pkgdesc="Script for sway and i3 to automatically switch the horizontal/vertical window split orientation"
 url="https://github.com/nwg-piotr/autotiling"
@@ -9,11 +9,15 @@ arch="noarch"
 options="!check" # no checks
 license="GPL-3.0-or-later"
 depends="py3-i3ipc"
+makedepends="py3-setuptools"
 source="$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/autotiling/archive/v$pkgver.tar.gz"
 
+build() {
+	python3 setup.py build
+}
+
 package() {
-	install -D -t "$pkgdir"/usr/lib/"$pkgname" autotiling.py
-	install -D -t "$pkgdir"/usr/bin autotiling
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="067f70e05c177a7532b33887b9817558b0f737edca4a0931e58441d2d7ffa3b360779246d25649ab649bad489dded89c8b1cb2e31a48be8749ccaa3ad88db380  autotiling-1.0.tar.gz"
+sha512sums="ff155c97299eb32c853de4c56aa8cea930416faa38c83062a273952dc7d5a3114d84b750abd498c8261135742cc2e1245743624ffd2f4acb961ca74c1a0d1889  autotiling-1.1.tar.gz"
-- 
GitLab