diff --git a/testing/ocaml-notty/APKBUILD b/testing/ocaml-notty/APKBUILD
index 7c3b4ad7b892a8bc828bc513fc9d3a4d9dcd4d5f..c6a14cffca2e2c64462a2d2671cfc12b16e671ed 100644
--- a/testing/ocaml-notty/APKBUILD
+++ b/testing/ocaml-notty/APKBUILD
@@ -2,9 +2,8 @@
 # Maintainer: Celeste <cielesti@protonmail.com>
 pkgname=ocaml-notty
 _pkgname=notty
-pkgver=0.2.2_git20200516
-_commit=67c602e3b32fdd6f4356c8e6b7537ff811ac14bf
-pkgrel=4
+pkgver=0.2.3
+pkgrel=0
 pkgdesc="Declarative terminal library for OCaml"
 url="https://github.com/pqwy/notty"
 arch="all !riscv64"  # limited by ocaml aport
@@ -17,10 +16,8 @@ depends_dev="
 	"
 makedepends="$depends_dev dune ocaml ocaml-cppo"
 subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/pqwy/notty/archive/$_commit/notty-$_commit.tar.gz
-	ocaml-4.14-support.patch
-	"
-builddir="$srcdir/$_pkgname-$_commit"
+source="$_pkgname-$pkgver.tar.bz2::https://github.com/pqwy/notty/releases/download/v$pkgver/notty-$pkgver.tbz"
+builddir="$srcdir/$_pkgname-$pkgver"
 _ocamldir=usr/lib/ocaml
 
 # 32-bit archs
@@ -33,7 +30,7 @@ build() {
 }
 
 check() {
-	dune runtest --verbose
+	dune runtest --build-dir=.testenv --verbose
 }
 
 package() {
@@ -81,6 +78,5 @@ scan_python3_dependency() {
 }
 
 sha512sums="
-58ec06c391bb9b95add279ec20c08a33c6aeb3aa66c0fcf4994ec335075ac3e25d8ece26ac75300608c1d2d15f75ad6e8caa8dbfa4f535d683b0bd9b170c7546  ocaml-notty-0.2.2_git20200516.tar.gz
-4c89e78ae0cf0f24bbb3259f31b6569f78ac130df208a573fadd1b6bbbb320fc6d357a2b119dee37a7c013d202887adf63d21a39523829e39cf52cc9a4a7041e  ocaml-4.14-support.patch
+6e21d44fe39f3d80884b87635bebae55cb2b931ef74f9184ba4d74cc3e51cb0b3e976c3b6dc61d377288504e8bfabe21acdc1069eacb30df1fbf6686b80f7c6b  notty-0.2.3.tar.bz2
 "
diff --git a/testing/ocaml-notty/ocaml-4.14-support.patch b/testing/ocaml-notty/ocaml-4.14-support.patch
deleted file mode 100644
index 3648994f6d40024e0472c3ae3d6c6c97dce81229..0000000000000000000000000000000000000000
--- a/testing/ocaml-notty/ocaml-4.14-support.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Taken from https://github.com/pqwy/notty/pull/35
-
---- a/src-unix/notty_unix.ml
-+++ b/src-unix/notty_unix.ml
-@@ -156,7 +156,7 @@
-             Buffer.reset t.buf; t.winched <- true; set_size t dim in f)
-     } in
-     winsize output |> iter (set_size t);
--    Lazy.force t.unwinch |> ignore;
-+    (Lazy.force t.unwinch |> ignore) [@ocaml.warning "-5"];
-     if dispose then at_exit (fun () -> release t);
-     write t;
-     t
---- a/src/dune
-+++ b/src/dune
-@@ -3,7 +3,7 @@
- (library
-   (public_name notty)
-   (synopsis "Declaring terminals")
--  (libraries uchar uutf)
-+  (libraries uutf)
-   (wrapped false)
-   (modules notty notty_grapheme_cluster notty_uucp notty_uucp_data)
-   (private_modules notty_grapheme_cluster notty_uucp notty_uucp_data))
-@@ -14,6 +14,7 @@
-   (name notty_top)
-   (wrapped false)
-   (modules notty_top)
-+  (preprocess (action (run %{bin:cppo} -V OCAML:%{ocaml_version} %{input-file})))
-   (libraries notty compiler-libs.toplevel))
- 
- (install
---- a/src/notty_top.ml
-+++ b/src/notty_top.ml
-@@ -1,4 +1,4 @@
- (* Copyright (c) 2017 David Kaloper Meršinjak. All rights reserved.
-    See LICENSE.md. *)
- 
--let _ = Toploop.use_silently Format.err_formatter "notty_top_init.ml"
-+let _ = Toploop.use_silently Format.err_formatter (Toploop.File "notty_top_init.ml")