diff --git a/community/py3-hyperlink/APKBUILD b/community/py3-hyperlink/APKBUILD
index 23382ea8fb35a0ab562becac2576c7aaf5773d89..813c5470ee11c12cb841f578475605478554a0ed 100644
--- a/community/py3-hyperlink/APKBUILD
+++ b/community/py3-hyperlink/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: prspkt <prspkt@protonmail.com>
 pkgname=py3-hyperlink
 _pkgname=hyperlink
-pkgver=20.0.1
+pkgver=21.0.0
 pkgrel=0
 pkgdesc="Python implementation of immutable URLs"
 url="https://github.com/python-hyper/hyperlink"
@@ -11,7 +11,7 @@ license="MIT"
 depends="py3-idna"
 makedepends="py3-setuptools"
 checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/h/hyperlink/hyperlink-$pkgver.tar.gz"
 builddir="$srcdir/"$_pkgname-$pkgver
 
 build() {
@@ -26,4 +26,4 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="f935c09d35baf8a8a3c8d4dc6aaf64135d13dda4636187f5d47f3fe4de675498efa29cd93d802c0912db2fa371d0e58213767b1c3c42e5a14bb837ea96a72193  hyperlink-20.0.1.tar.gz"
+sha512sums="9e0e9273dde1b0a41329a74fbb26c4f327b87f387ee64b9a2ab641ca5cc8b9ea0516884415e9adf1d4880ae9c053a5cba2c550fc508bb56fddb44a543d5da860  hyperlink-21.0.0.tar.gz"