From 75a967c09777888d0d603ad53cd0d1e5f42b0142 Mon Sep 17 00:00:00 2001
From: Newbyte <newbie13xd@gmail.com>
Date: Tue, 23 Apr 2024 22:46:43 +0200
Subject: [PATCH] community/phosh: enable systemd integration

With GNOME Session having systemd session support enabled this works
fine with elogind.

See https://gitlab.gnome.org/World/Phosh/phosh/-/merge_requests/1391
---
 community/phosh/APKBUILD | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/community/phosh/APKBUILD b/community/phosh/APKBUILD
index 7f0cc413090f..3e01874190b7 100644
--- a/community/phosh/APKBUILD
+++ b/community/phosh/APKBUILD
@@ -5,7 +5,7 @@
 # Maintainer: team/phosh <newbyte@postmarketos.org>
 pkgname=phosh
 pkgver=0.38.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Wayland shell for GNOME on mobile devices"
 # armhf: blocked by gnome-shell-schemas
 # Blocked on s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
@@ -67,7 +67,7 @@ build() {
 	abuild-meson \
 		-Db_lto=true \
 		-Dphoc_tests=disabled \
-		-Dsystemd=false \
+		-Dsystemd=true \
 		-Dman=true \
 		. output
 	meson compile -C output
@@ -82,6 +82,9 @@ package() {
 
 	install -D -m644 "$srcdir"/phosh.desktop \
 		"$pkgdir"/usr/share/wayland-sessions/phosh.desktop
+
+	# https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/64741#note_402279
+	rm -r "$pkgdir"/usr/lib/systemd
 }
 
 portalsconf() {
-- 
GitLab