diff --git a/testing/ocaml-extlib/APKBUILD b/testing/ocaml-extlib/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..9f1fa0e2507d656330ed4f79d831a68962106b13
--- /dev/null
+++ b/testing/ocaml-extlib/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fernando Casas Schossow <casasfernando@outlook.com>
+# Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
+pkgname=ocaml-extlib
+pkgver=1.7.5
+pkgrel=0
+pkgdesc="OCaml ExtLib additions to the standard library"
+url="https://github.com/ygrek/ocaml-extlib"
+arch="aarch64 ppc64le x86_64" # restricted by ocaml
+license="LGPL-2.1-or-later-WITH-linking-exception"
+makedepends="ocaml ocaml-findlib-dev ocaml-ocamldoc ocaml-cppo gawk"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/ygrek/ocaml-extlib/releases/download/$pkgver/extlib-$pkgver.tar.gz"
+builddir="$srcdir/extlib-$pkgver"
+
+build() {
+	cd "$builddir"
+	make build
+}
+
+check() {
+	cd "$builddir"
+	make test
+}
+
+package() {
+	cd "$builddir"
+	export DESTDIR="$pkgdir"
+	export OCAMLFIND_DESTDIR="$DESTDIR/usr/lib/ocaml"
+	mkdir -p "$OCAMLFIND_DESTDIR"
+	make install
+	install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha512sums="a2a368cf4f76b8a568b237efbb806bb6d16f9f46de1a3149d6381dadf9c464482276e160f9d4ae296f2540b6dd6f880a2cdb356133d31fa6001db4a392c3cb7f  extlib-1.7.5.tar.gz"