diff --git a/community/sic/APKBUILD b/community/sic/APKBUILD
index 569de4870c92333dc0e38a1837edb224bc01dca4..0bd4406359929ca4e04295cce579f943cd651104 100644
--- a/community/sic/APKBUILD
+++ b/community/sic/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=sic
-pkgver=1.2
-pkgrel=2
+pkgver=1.3
+pkgrel=0
 pkgdesc="an extremely simple IRC client"
 url="https://tools.suckless.org/sic"
 arch="all"
@@ -12,13 +12,6 @@ subpackages="$pkgname-doc"
 source="https://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz
 	musl-fix.patch"
 
-prepare() {
-	default_prepare
-	sed -i "$builddir/config.mk" \
-		-e '/CFLAGS/{s/-g -O0//;s/=/+=/}' \
-		-e '/LDFLAGS/{s/-s//;s/=/+=/}'
-}
-
 build() {
 	make PREFIX=/usr
 }
@@ -27,5 +20,7 @@ package() {
 	make DESTDIR="$pkgdir" PREFIX=/usr install
 }
 
-sha512sums="5659ed9d8a5986dda90dbe1155c27a5fd0ab4b1fcad2c1a20997c530bf03864e6c08bdeffc025c728629ab11872af6a1250761160b91f148dc37d77a49046dc9  sic-1.2.tar.gz
-94d9dc44a1a33c67141db312004a2c9d2113223c921ae210a6451b1c0f408d93fff4b16049f49d393ab4ca3ffca3fb5fc62265ec6195317abfbb70abdcd8ad5e  musl-fix.patch"
+sha512sums="
+0a5129dc9276c0a2c778d276115e96b5f11d7d6abce8cf2a5256a8b765a058c7a37bc6e86f90859015eb6b5b153e1c14fc6bbea6466f8ce0457edb7f2b89cbcb  sic-1.3.tar.gz
+7cac23919d2ce6e8c668c8d4424d49a4611dc0fb22da47dcb000f6f3a5063416dd644fcf19ed738cb8ff7c250a6282ebea10476c6870339365f0838253c3dc21  musl-fix.patch
+"
diff --git a/community/sic/musl-fix.patch b/community/sic/musl-fix.patch
index f04e32969892c1ec7c02629d2006cbba776315c5..04f1e14f42796ed3c0e9085e593aca3f0853628b 100644
--- a/community/sic/musl-fix.patch
+++ b/community/sic/musl-fix.patch
@@ -12,18 +12,14 @@ sic.c:137:17: error: storage size of 'tv' isn't known
  1 file changed, 2 insertions(+)
 
 diff --git a/sic.c b/sic.c
-index d93c2ec..e4bdb74 100644
+index c1e428e..3b6c7a3 100644
 --- a/sic.c
 +++ b/sic.c
-@@ -8,6 +8,8 @@
+@@ -9,6 +9,7 @@
+ #include <string.h>
  #include <time.h>
  #include <unistd.h>
- 
 +#include <sys/time.h>
-+
- static char *host = "irc.oftc.net";
- static char *port = "6667";
- static char *password;
--- 
-1.8.5.3
-
+ 
+ #include "arg.h"
+ #include "config.h"