From 72f38ece22272cb7bb278329c1ff67125cbefc77 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Sat, 3 Sep 2022 14:24:20 +0000
Subject: [PATCH] main/*: use meson test --print-errorlogs instead of -v

this is much less spammy in log output, as only actual errors are
printed instead of everything
---
 main/cairo/APKBUILD                 | 2 +-
 main/d-feet/APKBUILD                | 2 +-
 main/dav1d/APKBUILD                 | 2 +-
 main/fribidi/APKBUILD               | 2 +-
 main/gcr/APKBUILD                   | 2 +-
 main/gdk-pixbuf/APKBUILD            | 2 +-
 main/gobject-introspection/APKBUILD | 2 +-
 main/graphene/APKBUILD              | 2 +-
 main/gstreamer/APKBUILD             | 2 +-
 main/gtk+3.0/APKBUILD               | 2 +-
 main/harfbuzz/APKBUILD              | 2 +-
 main/libdrm/APKBUILD                | 2 +-
 main/libeconf/APKBUILD              | 2 +-
 main/libepoxy/APKBUILD              | 2 +-
 main/libsecret/APKBUILD             | 2 +-
 main/libsrtp/APKBUILD               | 2 +-
 main/libvdpau/APKBUILD              | 2 +-
 main/libxkbcommon/APKBUILD          | 2 +-
 main/orc/APKBUILD                   | 2 +-
 main/p11-kit/APKBUILD               | 2 +-
 main/pango/APKBUILD                 | 2 +-
 main/py3-cairo/APKBUILD             | 2 +-
 main/py3-gobject3/APKBUILD          | 2 +-
 main/shared-mime-info/APKBUILD      | 2 +-
 main/spice/APKBUILD                 | 2 +-
 main/tinyxml2/APKBUILD              | 2 +-
 main/wayland-protocols/APKBUILD     | 2 +-
 main/wayland/APKBUILD               | 2 +-
 main/xkeyboard-config/APKBUILD      | 2 +-
 29 files changed, 29 insertions(+), 29 deletions(-)

diff --git a/main/cairo/APKBUILD b/main/cairo/APKBUILD
index 5b075754c3d7..5dabd4ae8e94 100644
--- a/main/cairo/APKBUILD
+++ b/main/cairo/APKBUILD
@@ -55,7 +55,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/d-feet/APKBUILD b/main/d-feet/APKBUILD
index f18e741687f1..f693cdab1eca 100644
--- a/main/d-feet/APKBUILD
+++ b/main/d-feet/APKBUILD
@@ -29,7 +29,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/dav1d/APKBUILD b/main/dav1d/APKBUILD
index 86b359678280..7f5e4b174607 100644
--- a/main/dav1d/APKBUILD
+++ b/main/dav1d/APKBUILD
@@ -32,7 +32,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C build
+	meson test --no-rebuild --print-errorlogs -C build
 }
 
 package() {
diff --git a/main/fribidi/APKBUILD b/main/fribidi/APKBUILD
index 613785272b45..7d175de38aa7 100644
--- a/main/fribidi/APKBUILD
+++ b/main/fribidi/APKBUILD
@@ -26,7 +26,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/gcr/APKBUILD b/main/gcr/APKBUILD
index b2b5123529f7..fefb80ef2f58 100644
--- a/main/gcr/APKBUILD
+++ b/main/gcr/APKBUILD
@@ -42,7 +42,7 @@ build() {
 }
 
 check() {
-	xvfb-run meson test --no-rebuild -v -C output
+	xvfb-run meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/gdk-pixbuf/APKBUILD b/main/gdk-pixbuf/APKBUILD
index 1575c3c7a40f..1a8da712dd01 100644
--- a/main/gdk-pixbuf/APKBUILD
+++ b/main/gdk-pixbuf/APKBUILD
@@ -48,7 +48,7 @@ build() {
 }
 
 check() {
-	meson test -t 10 -v -C output
+	meson test -t 10 --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index 89f3e854a61d..809348834b06 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -23,7 +23,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/graphene/APKBUILD b/main/graphene/APKBUILD
index 29a1adb8a4f1..328578ca527d 100644
--- a/main/graphene/APKBUILD
+++ b/main/graphene/APKBUILD
@@ -33,7 +33,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/gstreamer/APKBUILD b/main/gstreamer/APKBUILD
index 2821deb2a2b1..5a9f21a966a4 100644
--- a/main/gstreamer/APKBUILD
+++ b/main/gstreamer/APKBUILD
@@ -43,7 +43,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/gtk+3.0/APKBUILD b/main/gtk+3.0/APKBUILD
index b950836f9256..dd89a31d912d 100644
--- a/main/gtk+3.0/APKBUILD
+++ b/main/gtk+3.0/APKBUILD
@@ -65,7 +65,7 @@ build() {
 }
 
 check() {
-	xvfb-run -a meson test --no-rebuild -v -C output
+	xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/harfbuzz/APKBUILD b/main/harfbuzz/APKBUILD
index 14ab68f7ad49..1d0549f02fb7 100644
--- a/main/harfbuzz/APKBUILD
+++ b/main/harfbuzz/APKBUILD
@@ -49,7 +49,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/libdrm/APKBUILD b/main/libdrm/APKBUILD
index 51a953046d85..856999919e53 100644
--- a/main/libdrm/APKBUILD
+++ b/main/libdrm/APKBUILD
@@ -32,7 +32,7 @@ build() {
 }
 
 check() {
-	meson test -v -C output
+	meson test --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/libeconf/APKBUILD b/main/libeconf/APKBUILD
index 9b4033ec21b4..098f9eb3110e 100644
--- a/main/libeconf/APKBUILD
+++ b/main/libeconf/APKBUILD
@@ -20,7 +20,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/libepoxy/APKBUILD b/main/libepoxy/APKBUILD
index 60871bcfaf16..71cbd2279e78 100644
--- a/main/libepoxy/APKBUILD
+++ b/main/libepoxy/APKBUILD
@@ -25,7 +25,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/libsecret/APKBUILD b/main/libsecret/APKBUILD
index e7752a4711c4..7528d678180c 100644
--- a/main/libsecret/APKBUILD
+++ b/main/libsecret/APKBUILD
@@ -23,7 +23,7 @@ build() {
 }
 
 check() {
-	xvfb-run meson test --no-rebuild -v -C output
+	xvfb-run meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/libsrtp/APKBUILD b/main/libsrtp/APKBUILD
index 5e3ed0d4635e..5eb2d8d246a6 100644
--- a/main/libsrtp/APKBUILD
+++ b/main/libsrtp/APKBUILD
@@ -23,7 +23,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C builddir
+	meson test --no-rebuild --print-errorlogs -C builddir
 }
 
 package() {
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
index d25a22696855..1563be26d067 100644
--- a/main/libvdpau/APKBUILD
+++ b/main/libvdpau/APKBUILD
@@ -19,7 +19,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/libxkbcommon/APKBUILD b/main/libxkbcommon/APKBUILD
index bc6a7bede5ee..b7b873cf6777 100644
--- a/main/libxkbcommon/APKBUILD
+++ b/main/libxkbcommon/APKBUILD
@@ -34,7 +34,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C build
+	meson test --no-rebuild --print-errorlogs -C build
 }
 
 package() {
diff --git a/main/orc/APKBUILD b/main/orc/APKBUILD
index 4f5db608d569..107e64502ceb 100644
--- a/main/orc/APKBUILD
+++ b/main/orc/APKBUILD
@@ -27,7 +27,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/p11-kit/APKBUILD b/main/p11-kit/APKBUILD
index 5166a3dc667e..4933cc2a7054 100644
--- a/main/p11-kit/APKBUILD
+++ b/main/p11-kit/APKBUILD
@@ -25,7 +25,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/pango/APKBUILD b/main/pango/APKBUILD
index a298b9f122ff..ca8acf4d1dd2 100644
--- a/main/pango/APKBUILD
+++ b/main/pango/APKBUILD
@@ -33,7 +33,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C build
+	meson test --no-rebuild --print-errorlogs -C build
 }
 
 package() {
diff --git a/main/py3-cairo/APKBUILD b/main/py3-cairo/APKBUILD
index 93eeda530495..b8ec90dd9b11 100644
--- a/main/py3-cairo/APKBUILD
+++ b/main/py3-cairo/APKBUILD
@@ -25,7 +25,7 @@ build() {
 }
 
 check() {
-	meson test -v --no-rebuild -C output
+	meson test --print-errorlogs --no-rebuild -C output
 }
 
 package() {
diff --git a/main/py3-gobject3/APKBUILD b/main/py3-gobject3/APKBUILD
index 527854fb3808..0945cc2b6113 100644
--- a/main/py3-gobject3/APKBUILD
+++ b/main/py3-gobject3/APKBUILD
@@ -33,7 +33,7 @@ build() {
 }
 
 check() {
-	PYGI_TEST_VERBOSE="1" xvfb-run -a meson test --no-rebuild -v -C output
+	PYGI_TEST_VERBOSE="1" xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/shared-mime-info/APKBUILD b/main/shared-mime-info/APKBUILD
index 95bf5750f817..58776c55430e 100644
--- a/main/shared-mime-info/APKBUILD
+++ b/main/shared-mime-info/APKBUILD
@@ -20,7 +20,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index 353a604b79d3..6ce812858d5f 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -59,7 +59,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/tinyxml2/APKBUILD b/main/tinyxml2/APKBUILD
index 1b42ce5a2556..0d52aa32d7f3 100644
--- a/main/tinyxml2/APKBUILD
+++ b/main/tinyxml2/APKBUILD
@@ -19,7 +19,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/wayland-protocols/APKBUILD b/main/wayland-protocols/APKBUILD
index 3fea4c76827e..6939ed4c9aba 100644
--- a/main/wayland-protocols/APKBUILD
+++ b/main/wayland-protocols/APKBUILD
@@ -18,7 +18,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/wayland/APKBUILD b/main/wayland/APKBUILD
index 13d3ff37fa15..3e5c437d4975 100644
--- a/main/wayland/APKBUILD
+++ b/main/wayland/APKBUILD
@@ -26,7 +26,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
diff --git a/main/xkeyboard-config/APKBUILD b/main/xkeyboard-config/APKBUILD
index 4ac9586ec27a..f2de2f207628 100644
--- a/main/xkeyboard-config/APKBUILD
+++ b/main/xkeyboard-config/APKBUILD
@@ -20,7 +20,7 @@ build() {
 }
 
 check() {
-	meson test --no-rebuild -v -C output
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
-- 
GitLab