Commit 729d2fa8 authored by Jakub Jirutka's avatar Jakub Jirutka

main/nginx: clean the mess with luajit condition

parent 7b7cc794
......@@ -5,7 +5,7 @@
pkgname=nginx
pkgver=1.10.3
pkgrel=4
pkgrel=5
pkgdesc="HTTP and reverse proxy server (stable version)"
url="http://www.nginx.org/en"
arch="all"
......@@ -52,8 +52,7 @@ _rtmp_dir="$srcdir/$_rtmp_name-$_rtmp_ver"
_rtmp_provides="$pkgname-rtmp" # for backward compatibility
depends=""
[ "$CARCH" == "s390x" ] && [ "$CARCH" == "ppc64le" ] && _lua_dep="lua5.1-dev" || _lua_dep="luajit-dev"
makedepends="linux-headers gd-dev geoip-dev libxml2-dev libxslt-dev $_lua_dep
makedepends="linux-headers gd-dev geoip-dev libxml2-dev libxslt-dev
libressl-dev paxmark pcre-dev perl-dev pkgconf zlib-dev"
pkgusers="nginx"
_grp_ngx="nginx"
......@@ -79,6 +78,12 @@ source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
"
builddir="$srcdir/$pkgname-$pkgver"
# luajit is not available for s390x and ppc64le
case "$CARCH" in
ppc64le | s390x) makedepends="$makedepends lua5.1-dev";;
*) makedepends="$makedepends luajit-dev";;
esac
_modules_dir="usr/lib/$pkgname/modules"
_modules="
http-geoip
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment