diff --git a/testing/criu/APKBUILD b/testing/criu/APKBUILD
index 3fae269dc929883733a197e2878974cb365e33cd..789a1eec0496c18db4b42961933540f50c7109c4 100644
--- a/testing/criu/APKBUILD
+++ b/testing/criu/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
 pkgname=criu
 pkgver=3.17.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Process tree checkpoint/restore utility"
 url="https://criu.org"
 arch="x86_64"
@@ -17,7 +17,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/checkpoint-restore/criu/arch
 build() {
 	# https://wiki.gentoo.org/wiki/Project:Quality_Assurance/As-needed
 	export LDFLAGS=$(echo $LDFLAGS |sed 's|-Wl,--as-needed||') PYTHON=python3
-	make
+	make -j1
 }
 
 check() {