Commit 70742b27 authored by Natanael Copa's avatar Natanael Copa

community/xfwm4: enable support for libxpresent

parent f8fe3f61
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org> # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfwm4 pkgname=xfwm4
pkgver=4.13.1 pkgver=4.13.1
pkgrel=0 pkgrel=1
pkgdesc="Xfce window manager, compatible with Gnome, Gnome2, KDE2, and KDE3" pkgdesc="Xfce window manager, compatible with Gnome, Gnome2, KDE2, and KDE3"
url="https://xfce.org/" url="https://xfce.org/"
arch="all" arch="all"
...@@ -10,7 +10,8 @@ license="GPL-2.0" ...@@ -10,7 +10,8 @@ license="GPL-2.0"
depends="hicolor-icon-theme" depends="hicolor-icon-theme"
subpackages="$pkgname-lang" subpackages="$pkgname-lang"
makedepends="libxfce4ui-dev libwnck3-dev libxrandr-dev libxcomposite-dev makedepends="libxfce4ui-dev libwnck3-dev libxrandr-dev libxcomposite-dev
libxfixes-dev libxdamage-dev libxrender-dev libepoxy-dev dbus-glib-dev" libxfixes-dev libxdamage-dev libxrender-dev libepoxy-dev dbus-glib-dev
libxpresent-dev"
install= install=
source="http://archive.xfce.org/src/xfce/xfwm4/${pkgver%.*}/xfwm4-$pkgver.tar.bz2" source="http://archive.xfce.org/src/xfce/xfwm4/${pkgver%.*}/xfwm4-$pkgver.tar.bz2"
...@@ -25,6 +26,8 @@ build () { ...@@ -25,6 +26,8 @@ build () {
--localstatedir=/var \ --localstatedir=/var \
--disable-static \ --disable-static \
--enable-compositor \ --enable-compositor \
--enable-startup-notification \
--enable-xpresent \
--enable-xsync --enable-xsync
make make
} }
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment