diff --git a/community/py3-amply/APKBUILD b/community/py3-amply/APKBUILD
index c23731181f896f3f9ec09f76646aa76f87d813fe..89d3ed69cbfabf1aa693e38f5d80c68f07092d38 100644
--- a/community/py3-amply/APKBUILD
+++ b/community/py3-amply/APKBUILD
@@ -9,7 +9,7 @@ arch="noarch"
 license="EPL-1.0"
 depends="python3 py3-parsing"
 makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
-checkdepends="py3-pytest"
+checkdepends="py3-pytest-xdist"
 subpackages="$pkgname-pyc"
 source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/a/amply/amply-$pkgver.tar.gz"
 builddir="$srcdir/amply-$pkgver"
@@ -23,7 +23,7 @@ build() {
 check() {
 	python3 -m venv --clear --without-pip --system-site-packages .testenv
 	.testenv/bin/python3 -m installer .dist/*.whl
-	.testenv/bin/python3 -m pytest
+	.testenv/bin/python3 -m pytest -n auto
 }
 
 package() {