From 6f29092322390cffae6d0ca22c1bcd0d1e1cbd9b Mon Sep 17 00:00:00 2001
From: J0WI <J0WI@users.noreply.github.com>
Date: Mon, 5 Jul 2021 23:07:54 +0200
Subject: [PATCH] community/alsa-*: update url and fix linter

---
 community/alsa-plugins/APKBUILD       | 26 ++++++++++++--------------
 community/alsa-tools/APKBUILD         |  6 +++---
 community/alsa-topology-conf/APKBUILD |  6 +++---
 community/alsa-ucm-conf/APKBUILD      |  6 +++---
 4 files changed, 21 insertions(+), 23 deletions(-)

diff --git a/community/alsa-plugins/APKBUILD b/community/alsa-plugins/APKBUILD
index ce976d1508a3..8ef4a1547466 100644
--- a/community/alsa-plugins/APKBUILD
+++ b/community/alsa-plugins/APKBUILD
@@ -3,9 +3,9 @@
 # Maintainer: Taner Tas <taner76@gmail.com>
 pkgname=alsa-plugins
 pkgver=1.2.2
-pkgrel=1
+pkgrel=2
 pkgdesc="Advanced Linux Sound Architecture (ALSA) plugins"
-url="https://www.alsa-project.org"
+url="https://alsa-project.org/"
 arch="all"
 license="GPL-2.0-or-later LGPL-2.1-or-later"
 makedepends="
@@ -24,9 +24,7 @@ subpackages="
 	$pkgname-a52
 	$pkgname-jack
 	"
-source="
-	ftp://ftp.alsa-project.org/pub/plugins/alsa-plugins-$pkgver.tar.bz2
-	"
+source="https://alsa-project.org/files/pub/plugins/alsa-plugins-$pkgver.tar.bz2"
 
 build() {
 	./configure \
@@ -54,41 +52,41 @@ EOF
 
 lavrate() {
 	pkgdesc="FFmpeg samplerate conversion plugins for alsa"
-	_mv_lib *lavrate*
+	_mv_lib ./*lavrate*
 	_mv_conf 10-rate-lav.conf
 }
 
 pulse() {
 	pkgdesc="Pulseaudio support plugins for alsa-only applications"
 	install_if="alsa-lib pulseaudio"
-	_mv_lib *pulse.so
-	_mv_conf *pulseaudio*
+	_mv_lib ./*pulse.so
+	_mv_conf ./*pulseaudio*
 	mv "$subpkgdir"/etc/alsa/conf.d/99-pulseaudio-default.conf.example \
 		"$subpkgdir"/etc/alsa/conf.d/99-pulseaudio-default.conf
 }
 
 a52() {
 	pkgdesc="Converts S16 linear sound format to A52 compressed format and sends it to an SPDIF output"
-	_mv_lib *a52.so
+	_mv_lib ./*a52.so
 	_mv_conf 60-a52-encoder.conf
 }
 
 jack() {
 	pkgdesc="Allows native ALSA applications to work with jackd"
-	_mv_lib *jack.so
+	_mv_lib ./*jack.so
 	_mv_conf 50-jack.conf
 }
 
 package() {
 	make DESTDIR="$pkgdir" install
-	find $pkgdir -name *.la -type f -exec rm -f {} \;
+	find $pkgdir -name "*.la" -type f -exec rm -f {} \;
 }
 
 _mv_lib() {
 	mkdir -p "$subpkgdir"/usr/lib/alsa-lib/
 
 	for i in "$@"; do
-	mv "$pkgdir"/usr/lib/alsa-lib/${i} \
+	mv "$pkgdir"/usr/lib/alsa-lib/$i \
 		"$subpkgdir"/usr/lib/alsa-lib/
 	done
 }
@@ -98,9 +96,9 @@ _mv_conf() {
 		"$subpkgdir"/usr/share/alsa/alsa.conf.d
 
 	for i in "$@"; do
-	mv "$pkgdir"/usr/share/alsa/alsa.conf.d/${i} \
+	mv "$pkgdir"/usr/share/alsa/alsa.conf.d/$i \
 		"$subpkgdir"/usr/share/alsa/alsa.conf.d/
-	mv "$pkgdir"/etc/alsa/conf.d/${i} \
+	mv "$pkgdir"/etc/alsa/conf.d/$i \
 		"$subpkgdir"/etc/alsa/conf.d/
 	done
 }
diff --git a/community/alsa-tools/APKBUILD b/community/alsa-tools/APKBUILD
index 7d4fe60277a2..8bcfacecd280 100644
--- a/community/alsa-tools/APKBUILD
+++ b/community/alsa-tools/APKBUILD
@@ -2,16 +2,16 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=alsa-tools
 pkgver=1.2.5
-pkgrel=0
+pkgrel=1
 pkgdesc="Advanced tools for certain sound cards"
-url="https://www.alsa-project.org"
+url="https://alsa-project.org/"
 arch="all"
 license="GPL-2.0-or-later"
 makedepends="fltk-dev gtk+2.0-dev gtk+3.0-dev alsa-lib-dev bash autoconf automake
 	libtool"
 options="!check" # No tests
 subpackages="$pkgname-dev $pkgname-doc $pkgname-gui:_gui"
-source="ftp://ftp.alsa-project.org/pub/tools/alsa-tools-$pkgver.tar.bz2"
+source="https://alsa-project.org/files/pub/tools/alsa-tools-$pkgver.tar.bz2"
 
 prepare() {
 	default_prepare
diff --git a/community/alsa-topology-conf/APKBUILD b/community/alsa-topology-conf/APKBUILD
index 844b6dd75e03..de55a3041bda 100644
--- a/community/alsa-topology-conf/APKBUILD
+++ b/community/alsa-topology-conf/APKBUILD
@@ -2,12 +2,12 @@
 # Maintainer: Minecrell <minecrell@minecrell.net>
 pkgname=alsa-topology-conf
 pkgver=1.2.5.1
-pkgrel=0
+pkgrel=1
 pkgdesc="ALSA topology configuration files"
-url="https://www.alsa-project.org"
+url="https://alsa-project.org/"
 arch="noarch"
 license="BSD-3-Clause"
-source="ftp://ftp.alsa-project.org/pub/lib/alsa-topology-conf-$pkgver.tar.bz2"
+source="https://alsa-project.org/files/pub/lib/alsa-topology-conf-$pkgver.tar.bz2"
 options="!check" # no tests
 
 package() {
diff --git a/community/alsa-ucm-conf/APKBUILD b/community/alsa-ucm-conf/APKBUILD
index 892b2c2175a7..919b9dcd9bc3 100644
--- a/community/alsa-ucm-conf/APKBUILD
+++ b/community/alsa-ucm-conf/APKBUILD
@@ -2,12 +2,12 @@
 # Maintainer: Minecrell <minecrell@minecrell.net>
 pkgname=alsa-ucm-conf
 pkgver=1.2.5.1
-pkgrel=0
+pkgrel=1
 pkgdesc="ALSA Use Case Manager configuration"
-url="https://www.alsa-project.org"
+url="https://alsa-project.org"
 arch="noarch"
 license="BSD-3-Clause"
-source="ftp://ftp.alsa-project.org/pub/lib/alsa-ucm-conf-$pkgver.tar.bz2"
+source="https://alsa-project.org/files/pub/lib/alsa-ucm-conf-$pkgver.tar.bz2"
 options="!check" # no tests
 
 package() {
-- 
GitLab