diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
index c4296a2f46213f6a05867d5876f2b81fc6e2d86e..0cf1932f0f4a0c685908ef86d25f7d4b83ea60ee 100644
--- a/community/whois/APKBUILD
+++ b/community/whois/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Stuart Cardall <developer@it-offshore.co.uk>
 # Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
 pkgname=whois
-pkgver=5.2.13
+pkgver=5.2.15
 pkgrel=0
 pkgdesc="Intelligent WHOIS client by Marco d'Itri"
 url="http://www.linux.it/~md/software/"
@@ -10,7 +10,8 @@ license="GPL2"
 makedepends="perl libidn-dev gettext-dev"
 subpackages="$pkgname-doc"
 source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/$pkgname/archive/v$pkgver.tar.gz
-	undefined-libintl.patch"
+	undefined-libintl.patch
+	"
 builddir="$srcdir/$pkgname-$pkgver"
 
 build() {
@@ -26,9 +27,5 @@ package() {
 	install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
 }
 
-md5sums="46cc9fe8c433491811077273eb933d84  whois-5.2.13.tar.gz
-2242ddc5ddd2bb98465e467e324de686  undefined-libintl.patch"
-sha256sums="d7af1e89e7b3c63835e78bcea6c8aeb14640a3f1027f18b7b619a47100a6f2dc  whois-5.2.13.tar.gz
-27876ce871f1116b6bc5baeab5176787b36c5ca1574dff2267b236f97b2a35d4  undefined-libintl.patch"
-sha512sums="b2292556a389fa3bccc6752abd085186822ed63230cd564636df52c7d50dad8c0e5476e4eff6bfbdd3dbc2346d9bb10f161e7b13898c1243dabdb60bf2e28730  whois-5.2.13.tar.gz
-83de8846813ee25acda5027a79b71932cdd8d9a13acac6f7d7831c1f84b154fb865abda510d82222e6edb344dead7f480734b1fe83dc3ba8a3ec81b35ba0ab69  undefined-libintl.patch"
+sha512sums="3dcf7767cc4bf96dd86489d531a110d9b596de2b307caa228c143c155a9ffc71b72e10628cadda5b85e61041ab61b3551b30de504bbad02fc7815b27c92836d8  whois-5.2.15.tar.gz
+efa32ec848e3d3e61481567815e8c02757eab32712eb5a431adb13b59fd359f735eb684fbdf8a5b8334410d17052dc93d65bdda27a328617e2b6772b23717487  undefined-libintl.patch"
diff --git a/community/whois/undefined-libintl.patch b/community/whois/undefined-libintl.patch
index 0150053a6557cc6b85f8b27bba0886204ee4de1f..1c9c7c134bb11c70ebdc51bea9e762dc35111352 100644
--- a/community/whois/undefined-libintl.patch
+++ b/community/whois/undefined-libintl.patch
@@ -1,11 +1,12 @@
---- whois-5.2.12/Makefile
-+++ whois-5.2.12/Makefile.new
+--- whois-5.2.15/Makefile
++++ whois-5.2.15/Makefile.new
 @@ -14,7 +14,7 @@
  
  # FreeBSD
  #whois_LDADD += -liconv
 -#LIBS += -L/usr/local/lib -lintl
 +LIBS += -lintl
- #INCLUDES += -I/usr/local/include
+ #DEFS += -I/usr/local/include
  
  # OS/2 EMX
+