diff --git a/main/libnetfilter_conntrack/APKBUILD b/main/libnetfilter_conntrack/APKBUILD
index e5b11a474f19a1653210f8890d2ddd3609295816..0faae9c332ca41a4f781fb951a995f9e1837907b 100644
--- a/main/libnetfilter_conntrack/APKBUILD
+++ b/main/libnetfilter_conntrack/APKBUILD
@@ -1,15 +1,17 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=libnetfilter_conntrack
-pkgver=1.0.8
-pkgrel=1
+pkgver=1.0.9
+pkgrel=0
 pkgdesc="programming interface (API) to the in-kernel connection tracking state table"
 url="https://www.netfilter.org/projects/libnetfilter_conntrack/"
 arch="all"
 license="GPL-2.0-or-later"
 makedepends="linux-headers libnfnetlink-dev libmnl-dev"
 subpackages="$pkgname-dev"
-source="https://www.netfilter.org/projects/libnetfilter_conntrack/files/libnetfilter_conntrack-$pkgver.tar.bz2"
+source="https://www.netfilter.org/projects/libnetfilter_conntrack/files/libnetfilter_conntrack-$pkgver.tar.bz2
+	fix_build_with_kernel_5.15_and_musl.patch
+	"
 
 build() {
 	./configure \
@@ -26,4 +28,7 @@ package() {
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="ddc70e7e3f2d764ed1e115e4a03fe8848b8c04bd69eea0952e63131dd4dae3c23f33b8be518673e1ec3b5dbf708f5f86eac97be46fe265d95386a5e902bd0b82  libnetfilter_conntrack-1.0.8.tar.bz2"
+sha512sums="
+e8b03425aaba3b72e6034c215656c34176d0550c08e0455aaeb1365d9141505d0c4feaa8978c8ccf2b7af9db6c9e874ceb866347e533b41cb03a189884f4004c  libnetfilter_conntrack-1.0.9.tar.bz2
+1a93a36cf5cb89cec08e6e2476bf8d6fc68e9608f55e370418ed6a87e369545bdff1050e810aab2d5a9706f9559b3c1c48c404d954b2d01b84dbd68bae063450  fix_build_with_kernel_5.15_and_musl.patch
+"
diff --git a/main/libnetfilter_conntrack/fix_build_with_kernel_5.15_and_musl.patch b/main/libnetfilter_conntrack/fix_build_with_kernel_5.15_and_musl.patch
new file mode 100644
index 0000000000000000000000000000000000000000..2e5608ae95c3009fdc07ffd3c2ad465295a48399
--- /dev/null
+++ b/main/libnetfilter_conntrack/fix_build_with_kernel_5.15_and_musl.patch
@@ -0,0 +1,56 @@
+From 21ee35dde73aec5eba35290587d479218c6dd824 Mon Sep 17 00:00:00 2001
+From: Robert Marko <robimarko@gmail.com>
+Date: Thu, 24 Feb 2022 15:01:11 +0100
+Subject: [PATCH] conntrack: fix build with kernel 5.15 and musl
+
+Currently, with kernel 5.15 headers and musl building is failing with
+redefinition errors due to a conflict between the kernel and musl headers.
+
+Musl is able to suppres the conflicting kernel header definitions if they
+are included after the standard libc ones, however since ICMP definitions
+were moved into a separate internal header to avoid duplication this has
+stopped working and is breaking the builds.
+
+It seems that the issue is that <netinet/in.h> which contains the UAPI
+suppression defines is included in the internal.h header and not in the
+proto.h which actually includes the kernel ICMP headers and thus UAPI
+supression defines are not present.
+
+Solve this by moving the <netinet/in.h> include before the ICMP kernel
+includes in the proto.h
+
+Fixes: bc1cb4b11403 ("conntrack: Move icmp request>reply type mapping to common file")
+Signed-off-by: Robert Marko <robimarko@gmail.com>
+Signed-off-by: Florian Westphal <fw@strlen.de>
+---
+ include/internal/internal.h | 1 -
+ include/internal/proto.h    | 1 +
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/internal/internal.h b/include/internal/internal.h
+index 2ef8a90..7cd7c44 100644
+--- a/include/internal/internal.h
++++ b/include/internal/internal.h
+@@ -14,7 +14,6 @@
+ #include <arpa/inet.h>
+ #include <time.h>
+ #include <errno.h>
+-#include <netinet/in.h>
+ 
+ #include <libnfnetlink/libnfnetlink.h>
+ #include <libnetfilter_conntrack/libnetfilter_conntrack.h>
+diff --git a/include/internal/proto.h b/include/internal/proto.h
+index 40e7bfe..60a5f4e 100644
+--- a/include/internal/proto.h
++++ b/include/internal/proto.h
+@@ -2,6 +2,7 @@
+ #define _NFCT_PROTO_H_
+ 
+ #include <stdint.h>
++#include <netinet/in.h>
+ #include <linux/icmp.h>
+ #include <linux/icmpv6.h>
+ 
+-- 
+2.37.1
+