From 6c43f531751a61824ce58ae87b8fed153fd0bc92 Mon Sep 17 00:00:00 2001
From: Duncan Bellamy <dunk@denkimushi.com>
Date: Sat, 14 Sep 2024 08:52:07 +0000
Subject: [PATCH] community/xnvme: upgrade to 0.7.5

* https://github.com/OpenMPDK/xNVMe/blob/v0.7.5/CHANGELOG.rst
---
 community/xnvme/APKBUILD       | 13 ++++++++-----
 community/xnvme/basename.patch | 13 +++++++++++++
 2 files changed, 21 insertions(+), 5 deletions(-)
 create mode 100644 community/xnvme/basename.patch

diff --git a/community/xnvme/APKBUILD b/community/xnvme/APKBUILD
index 7ca55c1e9994..bddc9cd7057f 100644
--- a/community/xnvme/APKBUILD
+++ b/community/xnvme/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Duncan Bellamy <dunk@denkimushi.com>
 # Maintainer: Duncan Bellamy <dunk@denkimushi.com>
 pkgname=xnvme
-pkgver=0.7.4
-pkgrel=2
+pkgver=0.7.5
+pkgrel=0
 pkgdesc="cross-platform libraries and tools for NVMe devices"
 url="https://xnvme.io"
 # 32bit unsupported
@@ -10,13 +10,15 @@ arch="all !armhf !armv7 !x86"
 license="BSD-3-Clause"
 makedepends="bsd-compat-headers libaio-dev liburing-dev linux-headers meson py3-gpep517 py3-setuptools py3-wheel"
 subpackages="py3-$pkgname-pyc py3-$pkgname:_python:noarch $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver-1.tar.gz::https://github.com/xnvme/xnvme/archive/refs/tags/v$pkgver.tar.gz"
+source="$pkgname-$pkgver-1.tar.gz::https://github.com/xnvme/xnvme/archive/refs/tags/v$pkgver.tar.gz
+	basename.patch
+	"
 case "$CARCH" in
 aarch64|x86_64) makedepends="$makedepends libvfn-dev" ;;
 esac
 
 build() {
-	abuild-meson -Dexamples=false -Dwith-spdk=false \
+	abuild-meson -Dexamples=false -Dwith-spdk=disabled \
 		. output
 	meson compile -C output
 
@@ -44,5 +46,6 @@ _python() {
 }
 
 sha512sums="
-407ea6695dc074e46c1a9666bc58ec05b4c7d5da272b991442d712558319b29246fe42572c7e105a72c0abfdff3e15919e60280591b60305a98331739bb8b84e  xnvme-0.7.4-1.tar.gz
+c82e1d8f5460e29270afd650c6726e2b1156f382d379e360c81246e1c651dad0b4ae814e0a3db495f83186269fe7c23ae0ea4488a39d10019a11e0a17ba0b014  xnvme-0.7.5-1.tar.gz
+c9bae17b305efc246fec3e3d9e02a9c3657cf210b1b5ece2af40fb0c69428be720e0e2f94c857860691922175c4e77de964a1c91b7468dd44ed5413f85f14e0f  basename.patch
 "
diff --git a/community/xnvme/basename.patch b/community/xnvme/basename.patch
new file mode 100644
index 000000000000..d2ecc26a23c5
--- /dev/null
+++ b/community/xnvme/basename.patch
@@ -0,0 +1,13 @@
+diff -Nurp a/lib/xnvme_be_linux_nvme.c b/lib/xnvme_be_linux_nvme.c
+--- a/lib/xnvme_be_linux_nvme.c	2024-09-11 11:56:13.000000000 +0000
++++ b/lib/xnvme_be_linux_nvme.c	2024-09-14 09:12:37.198486113 +0000
+@@ -18,6 +18,9 @@
+ #include <xnvme_be_linux.h>
+ #include <xnvme_be_linux_nvme.h>
+ #include <xnvme_spec.h>
++#if defined(__linux__) && !defined(__GLIBC__)
++#include "libgen.h" // for basename
++#endif
+ 
+ #ifdef XNVME_DEBUG_ENABLED
+ static const char *
-- 
GitLab