From 6b00d202588a97009cd4774932a42c801080ceed Mon Sep 17 00:00:00 2001
From: omni <omni+alpine@hack.org>
Date: Mon, 27 Sep 2021 00:04:48 +0000
Subject: [PATCH] testing/ocaml-qtest: upgrade to 2.11

Also enable on archs supported by ocaml aport
---
 testing/ocaml-qtest/APKBUILD | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

diff --git a/testing/ocaml-qtest/APKBUILD b/testing/ocaml-qtest/APKBUILD
index 1b0621e2ad3d..fc1b351a4d09 100644
--- a/testing/ocaml-qtest/APKBUILD
+++ b/testing/ocaml-qtest/APKBUILD
@@ -2,11 +2,11 @@
 # Maintainer: Andy Li <andy@onthewings.net>
 pkgname=ocaml-qtest
 _pkgname=qtest
-pkgver=2.10.1
+pkgver=2.11
 pkgrel=0
 pkgdesc="Lightweight inline test extraction from comments"
 url="https://github.com/vincent-hugot/qtest"
-arch="all !x86 !armhf !armv7 !s390x !mips !mips64 !riscv64"  # limited by ocaml aport
+arch="all !mips64 !riscv64"  # limited by ocaml aport
 license="GPL-3.0-or-later"
 depends="ocaml-runtime ocaml-qcheck"
 depends_dev="$pkgname=$pkgver-r$pkgrel"
@@ -15,6 +15,11 @@ subpackages="$pkgname-dev"
 source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$pkgver"
 
+# 32bit archs
+case "$CARCH" in
+    arm*|x86) options="$options textrels" ;;
+esac
+
 build() {
 	dune build @install -p qtest -j1 --no-buffer --verbose
 }
@@ -53,4 +58,4 @@ dev() {
 		-exec sh -c 'mkdir -p "$(dirname $1)" && mv "$1" "$subpkgdir/$(dirname $1)/"' _ {} \;
 }
 
-sha512sums="838ff1951b8da35f0551b1db4d36a03ad803a57ba8b85816a51e6b1bc2ad7778299a7fd026a062437252b40c0de1c83b6171605b19f01e3874274b2676341bf0  ocaml-qtest-2.10.1.tar.gz"
+sha512sums="ea0d08aa927bfea71f04ed9d6bc66512b95432cbba5a8f3d77d0ebf5bbd5969f33c68ee95c03dd94b19c6a54b92c08d3b69b5ab35414650b3581d946b75b1698  ocaml-qtest-2.11.tar.gz"
-- 
GitLab