diff --git a/community/libxpresent/APKBUILD b/community/libxpresent/APKBUILD
index 3211f1549964781f3e047f81efc7a9bcad1f8630..2590aa25c819ad8ec534debef35f94ca833603a0 100644
--- a/community/libxpresent/APKBUILD
+++ b/community/libxpresent/APKBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=libxpresent
-pkgver=1.0.0
+pkgver=1.0.1
 pkgrel=0
 pkgdesc="A Xlib-compatible API for the Present extension"
 url="http://xorg.freedesktop.org/"
@@ -15,17 +15,10 @@ makedepends="
 	xorgproto
 	"
 subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/lib/libXpresent-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/lib/libXpresent-$pkgver.tar.xz"
 options="!check" # No test suite
 builddir="$srcdir/libXpresent-$pkgver"
 
-prepare() {
-	default_prepare
-
-	update_config_sub
-	update_config_guess
-}
-
 build() {
 	./configure \
 		--build=$CBUILD \
@@ -41,4 +34,6 @@ package() {
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="e88b4ec4fcbc0417a0cbecc0ecd73f8085c496dc6d1a4902b6550750a69a1cb8bb76c436c7941ee3bf3c61ffc85bbd8f8327fca30f14815dbef1cd53bb8db16b  libXpresent-1.0.0.tar.bz2"
+sha512sums="
+a4551f49a68f4487eb70dc5b50b7f745fbc8b6842cfa60422afe3834af41c504a37bcfddb4e7e9ee084b250df256034290776c8eb7d8838e392eb626fff55d25  libXpresent-1.0.1.tar.xz
+"