diff --git a/community/passt/APKBUILD b/community/passt/APKBUILD
index 47d0a56c21ff0d55684d977ba796108cd77ebde6..ffe8a4fc2546d1c375949ff2dd63a1a1833da005 100644
--- a/community/passt/APKBUILD
+++ b/community/passt/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Hoang Nguyen <folliekazetani@protonmail.com>
 # Maintainer: omni <omni+alpine@hack.org>
 pkgname=passt
-pkgver=2024.06.07
-_commit=8a83b53
+pkgver=2024.11.21
+_commit=238c69f
 _tag=${pkgver//./_}.$_commit
 pkgrel=0
 pkgdesc="Plug A Simple Socket Transport"
@@ -13,11 +13,16 @@ makedepends="coreutils-fmt linux-headers"
 subpackages="$pkgname-doc"
 source="https://passt.top/passt/snapshot/passt-$_tag.tar.gz"
 builddir="$srcdir/$pkgname-$_tag"
-# complicated test setup, requires qemu and a lot of VM images
-options="!check"
 
 build() {
-	make
+	make VERSION="$_tag"
+}
+
+check() {
+	# complicated test setup, requires qemu and a lot of VM images
+	# let's just at least do this
+	./passt --version
+	./pasta --version
 }
 
 package() {
@@ -26,5 +31,5 @@ package() {
 }
 
 sha512sums="
-a4de28737934731e9837555fa96e56beccfcd70977665e7a9178d0caa46cf36d0920122b7b50b45ccf6c3bf2d58d99be5837b059a18a24cacda754328f096497  passt-2024_06_07.8a83b53.tar.gz
+b4dec6ed8334ede858fbd9efafa72aa846b7ed8fd41c3544b63690d7f76de6c738193111a980b266966a19d3f4383df11c3473b615b870e265dc7e8f4e53b004  passt-2024_11_21.238c69f.tar.gz
 "