diff --git a/unmaintained/gnome-books/APKBUILD b/community/gnome-books/APKBUILD
similarity index 67%
rename from unmaintained/gnome-books/APKBUILD
rename to community/gnome-books/APKBUILD
index dd5c3977b817adeb83197ba7c1ccb3d4fff2f456..a685af821289dab3e6a0162bab406308edf6e448 100644
--- a/unmaintained/gnome-books/APKBUILD
+++ b/community/gnome-books/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Rasmus Thomsen <oss@cogitri.dev>
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=gnome-books
-pkgver=3.34.0
-pkgrel=9
+pkgver=40.0
+pkgrel=0
 pkgdesc="GNOME Ebook Manager"
 url="https://wiki.gnome.org/Apps/Books"
 arch="all !s390x !mips !mips64" # missing gjs, librsvg
@@ -14,8 +14,7 @@ checkdepends="appstream-glib desktop-file-utils"
 # Don't conflict with other packages doing a shared link of libgd
 sonameprefix="$pkgname:"
 subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/gnome-books/${pkgver%.*}/gnome-books-$pkgver.tar.xz
-	504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b.patch"
+source="https://download.gnome.org/sources/gnome-books/${pkgver%.*}/gnome-books-$pkgver.tar.xz"
 
 build() {
 	abuild-meson . output
@@ -30,5 +29,4 @@ package() {
 	DESTDIR="$pkgdir" meson install --no-rebuild -C output
 }
 
-sha512sums="634dcd7e26ede955e8700335fcd04ab4bd40d083d251846f66a46dac49b7525e011b31de0b60585ed643d04798e472f4fbd69c872cdeed7fa36bcc445ff03016  gnome-books-3.34.0.tar.xz
-c8f2a22cd2226d531cb9a39edab133444583647f1e2ab940de08d05bb1816ad356229164a2adac10bb5f02ef663f7124b211f2cfb00670a148f396c075d02222  504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b.patch"
+sha512sums="6fb6df65a493c0813cc742c08309d104ef4cc66c21d1a50e6e756824f16eec4350c89b8b7c23de35784e21197649e2390d69850632d279305ed172dfafe5ef41  gnome-books-40.0.tar.xz"
diff --git a/unmaintained/gnome-books/504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b.patch b/unmaintained/gnome-books/504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b.patch
deleted file mode 100644
index ea8ecd632e343a9f21b50cb66c0470c9b97e7263..0000000000000000000000000000000000000000
--- a/unmaintained/gnome-books/504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Upstream: Yes, https://gitlab.gnome.org/GNOME/gnome-books/-/commit/504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b
-From 504b66f6cec4b7a7bb46ca7a3b27a47ffb6a424b Mon Sep 17 00:00:00 2001
-From: Bastien Nocera <hadess@hadess.net>
-Date: Fri, 20 Sep 2019 12:31:35 +0200
-Subject: [PATCH] overview: Handle unset documents xdg-user-dir
-
-Don't crash if the documents xdg-user-dir is unset on badly installed
-systems.
-
-JS ERROR: Exception in callback for signal: window-mode-changed: Error: Argument 'path' (type filename) may not be null
-_addSecondaryLabel@resource:///org/gnome/Books/js/overview.js:308:23
-
-Closes: #39
----
- src/overview.js | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/overview.js b/src/overview.js
-index 18a51f1a..a1b0d246 100644
---- a/src/overview.js
-+++ b/src/overview.js
-@@ -305,6 +305,8 @@ const EmptyResultsBox = new Lang.Class({
-             let docsPath, docsUrl;
- 
-             docsPath = GLib.get_user_special_dir(GLib.UserDirectory.DIRECTORY_DOCUMENTS);
-+            if (!docsPath)
-+                docsPath = GLib.get_home_dir();
-             docsUrl = Gio.file_new_for_path(docsPath).get_uri();
-             useMarkup = true;
-             /* translators: %s is the location of the Documents folder.*/
--- 
-2.24.1
-