diff --git a/testing/py3-ast-monitor/APKBUILD b/testing/py3-ast-monitor/APKBUILD
index 3be414faa3653ff33ca1de3f573eaeee40c76fe5..2450cc315f06566623d0aa97c65203aef95b9762 100644
--- a/testing/py3-ast-monitor/APKBUILD
+++ b/testing/py3-ast-monitor/APKBUILD
@@ -1,8 +1,7 @@
 # Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
 # Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
 pkgname=py3-ast-monitor
-_pkgorig=ast_monitor
-pkgver=0.1.3
+pkgver=0.1.4
 pkgrel=0
 pkgdesc="A wearable Raspberry Pi computer for cyclists"
 url="https://github.com/firefly-cpp/AST-Monitor"
@@ -18,12 +17,12 @@ depends="
 	py3-tcxreader
 	"
 checkdepends="python3-dev py3-pytest"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/a/ast-monitor/ast_monitor-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgorig-$pkgver"
+makedepends="py3-build py3-poetry-core py3-wheel py3-installer"
+source="https://github.com/firefly-cpp/AST-Monitor/archive/$pkgver/ast_monitor-$pkgver.tar.gz"
+builddir="$srcdir/AST-Monitor-$pkgver"
 
 build() {
-	python3 setup.py build
+	GIT_DIR="$builddir" python3 -m build --no-isolation --wheel
 }
 
 check() {
@@ -31,9 +30,10 @@ check() {
 }
 
 package() {
-	python3 setup.py install --prefix=/usr --root="$pkgdir"
+	python3 -m installer -d "$pkgdir" \
+		dist/ast_monitor-$pkgver-py3-none-any.whl
 }
 
 sha512sums="
-d882da6b006624e8f39af7738debb0239ad8a11287240a45c7a8d829d22f2ff6a44035bab76c503778c9a3c12e82ced16afb7dae363346050ac2ee4dcc1dc004  py3-ast-monitor-0.1.3.tar.gz
+30636d3fb45baa83f605dcf35710a6ff8fe48678832c043adc982aa2f4e822e9a814cb00d3126585008515c5490a74ced8ffbea25f00c3480075537cbe847db2  ast_monitor-0.1.4.tar.gz
 "