From 6928abc43e245aae98a620afa35a1c76c7e55417 Mon Sep 17 00:00:00 2001
From: Francesco Colista <fcolista@alpinelinux.org>
Date: Thu, 15 Dec 2016 07:45:15 +0000
Subject: [PATCH] testing/py-pam: new aport

---
 testing/py-pam/APKBUILD                       |  71 +++++++
 testing/py-pam/PyPAM-0.5.0-dealloc.patch      |  17 ++
 .../py-pam/PyPAM-0.5.0-memory-errors.patch    | 128 +++++++++++
 testing/py-pam/PyPAM-0.5.0-nofree.patch       |  60 ++++++
 testing/py-pam/PyPAM-0.5.0-return-value.patch |  57 +++++
 testing/py-pam/PyPAM-python3-support.patch    | 198 ++++++++++++++++++
 testing/py-pam/pypam-0.5.0-stricter.patch     |  15 ++
 7 files changed, 546 insertions(+)
 create mode 100644 testing/py-pam/APKBUILD
 create mode 100644 testing/py-pam/PyPAM-0.5.0-dealloc.patch
 create mode 100644 testing/py-pam/PyPAM-0.5.0-memory-errors.patch
 create mode 100644 testing/py-pam/PyPAM-0.5.0-nofree.patch
 create mode 100644 testing/py-pam/PyPAM-0.5.0-return-value.patch
 create mode 100644 testing/py-pam/PyPAM-python3-support.patch
 create mode 100644 testing/py-pam/pypam-0.5.0-stricter.patch

diff --git a/testing/py-pam/APKBUILD b/testing/py-pam/APKBUILD
new file mode 100644
index 000000000000..d1bb0a24e84c
--- /dev/null
+++ b/testing/py-pam/APKBUILD
@@ -0,0 +1,71 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-pam
+_pkgname=PyPAM
+_id="f1e7c2c56421dda28a75ace59a3c8871"
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A Python interface to the PAM library "
+url="https://launchpad.net/ubuntu/quantal/+source/python-pam"
+arch="all"
+license="LGPL-2.1"
+depends="linux-pam"
+makedepends="python2-dev py-setuptools python3-dev linux-headers linux-pam-dev"
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="http://pkgs.fedoraproject.org/lookaside/pkgs/$_pkgname/$_pkgname-$pkgver.tar.gz/$_id/$_pkgname-$pkgver.tar.gz
+PyPAM-0.5.0-dealloc.patch
+PyPAM-0.5.0-nofree.patch
+PyPAM-0.5.0-memory-errors.patch
+PyPAM-0.5.0-return-value.patch
+PyPAM-python3-support.patch
+pypam-0.5.0-stricter.patch"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+	cd "$builddir"
+	python2 setup.py build || return 1
+	python3 setup.py build || return 1	
+}
+
+package() {
+	mkdir -p "$pkgdir"
+}
+
+_py() {
+	local python=$1
+	pkgdesc="$pkgdesc (for $python)"
+	install_if="$pkgname=$pkgver-r$pkgrel $python" 	
+	cd "$builddir"
+	$python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+	replaces="$pkgname"
+	_py python2
+}
+
+_py3() {
+	_py python3
+}
+
+md5sums="f1e7c2c56421dda28a75ace59a3c8871  PyPAM-0.5.0.tar.gz
+1c893c85d63378bb05d8cd07bffc97e7  PyPAM-0.5.0-dealloc.patch
+0663d74895ca602bf184e1898a34116d  PyPAM-0.5.0-nofree.patch
+9ee809416aa3ab00655043f01cd3522f  PyPAM-0.5.0-memory-errors.patch
+6a7ea0a074f5b51598da4ee3bbbb95ee  PyPAM-0.5.0-return-value.patch
+ad43b2cbee367cdcb9c6fbd0d3c1cf48  PyPAM-python3-support.patch
+da0356df36055b1175e14643d6163e01  pypam-0.5.0-stricter.patch"
+sha256sums="796ac019b9ee805696d0d277d8fb912fa2391b6ac070dc6f9f1a9a0fadbc3a5a  PyPAM-0.5.0.tar.gz
+5d73ad2efb9b5f0507c1968aa69bcc36d3981e5c02117215982abbb6825863de  PyPAM-0.5.0-dealloc.patch
+ed2964fbc2c0d8b23961cf3a9b5b77d8c4609de54ef0e557ecb64664497f8ff9  PyPAM-0.5.0-nofree.patch
+e500628d9ccae7c953967a70a97b3af94c5f6c52849b6615b0d1270789a1d08a  PyPAM-0.5.0-memory-errors.patch
+8a5a7292b415b053a69ccb36f7cd5dfd367f273b0ca8cf1f1bcec96f05769b3e  PyPAM-0.5.0-return-value.patch
+e51058c0869eb0b5364c1978f865ceea01f8b9e9957695629ce61bf8417838b0  PyPAM-python3-support.patch
+ad12759aeb86af08c590c91995ef36ee8e887523f8a2cf49b28e1e9034608d6c  pypam-0.5.0-stricter.patch"
+sha512sums="9e0e919e34930d2283307cd6665c5287c664a76a5de56367bd975867ac26b376ae03d30cb3bc4a16390c977ca2690cfd2e90ac73dcc7886b8c999444da4a07e0  PyPAM-0.5.0.tar.gz
+105573489be31763ed01bab02ccaf7147c73b196d85d8318eceda145e86fb5c3fa3a59b7baee9d85f6d5ae40df0335689267650461f5440a9c2991954c367e8e  PyPAM-0.5.0-dealloc.patch
+7292483d60f75d577055f4bf7380b110620669a19b3e2e3a4700e2c816758af865213cf19b329260338e82f9a0cba03a14dea06ba636251f1436ec0c3373f751  PyPAM-0.5.0-nofree.patch
+358e57ba6450b533cbdb39f559813767799e387937a610b15e5e8e78d59b6501785c40c3ffdc5b1914ff6c9220716cdf9b537847373379eb94094f6ffe23c7f5  PyPAM-0.5.0-memory-errors.patch
+73d81d9a7398933011eba0739e3bce7651c3da1bf38f77b510172e26f569d329c3b28e5192a25ee0616875ddad52e67697dabe021d31cc5e51e9e78941333c8d  PyPAM-0.5.0-return-value.patch
+4dd78df5984601cf47aebaa77665730c32b4f0550feb8c12af4b145643584aad9d4b184b2c8fb67cc0503ad791a1d772a01db478795407b5c755dcbd172dabd0  PyPAM-python3-support.patch
+8a059951cc219278a36e7e0ec50aba2799d664f74389735e3b32ff2bd7fd45e0d712d0487662879bc07b3bd7fdf74acae7c459dfc16731ad90e8e83b2c215cbd  pypam-0.5.0-stricter.patch"
diff --git a/testing/py-pam/PyPAM-0.5.0-dealloc.patch b/testing/py-pam/PyPAM-0.5.0-dealloc.patch
new file mode 100644
index 000000000000..b73dd0b08c59
--- /dev/null
+++ b/testing/py-pam/PyPAM-0.5.0-dealloc.patch
@@ -0,0 +1,17 @@
+diff -up PyPAM-0.5.0/PAMmodule.c.dealloc PyPAM-0.5.0/PAMmodule.c
+--- PyPAM-0.5.0/PAMmodule.c.dealloc	2011-01-17 22:48:22.000000000 +0100
++++ PyPAM-0.5.0/PAMmodule.c	2011-01-18 21:24:59.000000000 +0100
+@@ -538,10 +538,11 @@ static void PyPAM_dealloc(PyPAMObject *s
+     free(self->service);
+     free(self->user);
+     free(self->conv);
+-    pam_end(self->pamh, PAM_SUCCESS);
++    if (self->pamh)
++        pam_end(self->pamh, PAM_SUCCESS);
+     dlclose(self->dlh2);
+     dlclose(self->dlh1);
+-    PyMem_DEL(self);
++    PyObject_Del(self);
+ }
+ 
+ static PyObject * PyPAM_getattr(PyPAMObject *self, char *name)
diff --git a/testing/py-pam/PyPAM-0.5.0-memory-errors.patch b/testing/py-pam/PyPAM-0.5.0-memory-errors.patch
new file mode 100644
index 000000000000..6e0b4c0dce4b
--- /dev/null
+++ b/testing/py-pam/PyPAM-0.5.0-memory-errors.patch
@@ -0,0 +1,128 @@
+diff -up PyPAM-0.5.0/PAMmodule.c.memory PyPAM-0.5.0/PAMmodule.c
+--- PyPAM-0.5.0/PAMmodule.c.memory	2012-05-07 17:22:54.503914026 +0200
++++ PyPAM-0.5.0/PAMmodule.c	2012-05-07 17:23:15.644381942 +0200
+@@ -37,33 +37,48 @@ static void PyPAM_Err(PyPAMObject *self,
+ 
+     err_msg = pam_strerror(self->pamh, result);
+     error = Py_BuildValue("(si)", err_msg, result);
+-    Py_INCREF(PyPAM_Error);
+     PyErr_SetObject(PyPAM_Error, error);
++    Py_XDECREF(error);
+ }
+ 
+ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
+     struct pam_response **resp, void *appdata_ptr)
+ {
+-    PyObject                *args;
+-
++    PyObject *args, *msgList, *respList, *item;
++    struct pam_response *response, *spr;
+     PyPAMObject* self = (PyPAMObject *) appdata_ptr;
++
+     if (self->callback == NULL)
+         return PAM_CONV_ERR;
+ 
+     Py_INCREF(self);
+ 
+-    PyObject* msgList = PyList_New(num_msg);
+-    
++    msgList = PyList_New(num_msg);
++    if (msgList == NULL) {
++        Py_DECREF(self);
++        return PAM_CONV_ERR;
++    }
++
+     for (int i = 0; i < num_msg; i++) {
+-        PyList_SetItem(msgList, i,
+-            Py_BuildValue("(si)", msg[i]->msg, msg[i]->msg_style));
++        item = Py_BuildValue("(si)", msg[i]->msg, msg[i]->msg_style);
++        if (item == NULL) {
++            Py_DECREF(msgList);
++            Py_DECREF(self);
++            return PAM_CONV_ERR;
++        }
++        PyList_SetItem(msgList, i, item);
+     }
+-    
++
+     args = Py_BuildValue("(OO)", self, msgList);
+-    PyObject* respList = PyEval_CallObject(self->callback, args);
++    if (args == NULL) {
++        Py_DECREF(self);
++	Py_DECREF(msgList);
++        return PAM_CONV_ERR;
++    }
++    respList = PyEval_CallObject(self->callback, args);
+     Py_DECREF(args);
+     Py_DECREF(self);
+-    
++
+     if (respList == NULL)
+         return PAM_CONV_ERR;
+ 
+@@ -71,11 +86,15 @@ static int PyPAM_conv(int num_msg, const
+         Py_DECREF(respList);
+         return PAM_CONV_ERR;
+     }
+-    
+-    *resp = (struct pam_response *) malloc(
++
++    response = (struct pam_response *) malloc(
+         PyList_Size(respList) * sizeof(struct pam_response));
++    if (response == NULL) {
++        Py_DECREF(respList);
++        return PAM_CONV_ERR;
++    }
++    spr = response;
+ 
+-    struct pam_response* spr = *resp;
+     for (int i = 0; i < PyList_Size(respList); i++, spr++) {
+         PyObject* respTuple = PyList_GetItem(respList, i);
+         char* resp_text;
+@@ -85,7 +104,7 @@ static int PyPAM_conv(int num_msg, const
+                 free((--spr)->resp);
+                 --i;
+             }
+-            free(*resp);
++            free(response);
+             Py_DECREF(respList);
+             return PAM_CONV_ERR;
+         }
+@@ -95,7 +114,8 @@ static int PyPAM_conv(int num_msg, const
+     }
+ 
+     Py_DECREF(respList);
+-    
++    *resp = response;
++
+     return PAM_SUCCESS;
+ }
+ 
+@@ -122,7 +142,11 @@ static PyObject * PyPAM_pam(PyObject *se
+     PyPAMObject_Type.ob_type = &PyType_Type;
+     p = (PyPAMObject *) PyObject_NEW(PyPAMObject, &PyPAMObject_Type);
+ 
++    if (p == NULL)
++        return NULL;
++
+     if ((spc = (struct pam_conv *) malloc(sizeof(struct pam_conv))) == NULL) {
++        Py_DECREF((PyObject *)p);
+         PyErr_SetString(PyExc_MemoryError, "out of memory");
+         return NULL;
+     }
+@@ -455,9 +479,15 @@ static PyObject * PyPAM_getenvlist(PyObj
+     }
+     
+     retval = PyList_New(0);
++    if (retval == NULL)
++	return NULL;
+     
+     while ((cp = *(result++)) != NULL) {
+         entry = Py_BuildValue("s", cp);
++        if (entry == NULL) {
++            Py_DECREF(retval);
++            return NULL;
++        }
+         PyList_Append(retval, entry);
+         Py_DECREF(entry);
+     }
diff --git a/testing/py-pam/PyPAM-0.5.0-nofree.patch b/testing/py-pam/PyPAM-0.5.0-nofree.patch
new file mode 100644
index 000000000000..f27e9d543d06
--- /dev/null
+++ b/testing/py-pam/PyPAM-0.5.0-nofree.patch
@@ -0,0 +1,60 @@
+diff --git a/PAMmodule.c b/PAMmodule.c
+index 03cb799..a7ff8a5 100644
+--- a/PAMmodule.c
++++ b/PAMmodule.c
+@@ -24,8 +24,6 @@ typedef struct {
+     char                *service;
+     char                *user;
+     PyObject            *callback;
+-    struct pam_response *response_data;
+-    int                 response_len;
+     PyObject            *user_data;
+     void                *dlh1, *dlh2;
+ } PyPAMObject;
+@@ -54,15 +52,6 @@ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
+ 
+     Py_INCREF(self);
+ 
+-    if (NULL != self->response_data) {
+-        for (int i = 0; i < self->response_len; i++) {
+-            free(self->response_data[0].resp);
+-        }
+-        free(self->response_data);
+-        self->response_data = NULL;
+-        self->response_len = 0;
+-    }
+-
+     PyObject* msgList = PyList_New(num_msg);
+     
+     for (int i = 0; i < num_msg; i++) {
+@@ -92,6 +81,10 @@ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
+         char* resp_text;
+         int resp_retcode = 0;
+         if (!PyArg_ParseTuple(respTuple, "si", &resp_text, &resp_retcode)) {
++            while (i > 0) {
++                free((--spr)->resp);
++                --i;
++            }
+             free(*resp);
+             Py_DECREF(respList);
+             return PAM_CONV_ERR;
+@@ -100,10 +93,6 @@ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
+         spr->resp_retcode = resp_retcode;
+         Py_DECREF(respTuple);
+     }
+-    
+-    // Save this so we can free it later.
+-    self->response_data = *resp;
+-    self->response_len = PyList_Size(respList);
+ 
+     Py_DECREF(respList);
+     
+@@ -144,8 +133,6 @@ static PyObject * PyPAM_pam(PyObject *self, PyObject *args)
+     p->user = NULL;
+     Py_INCREF(Py_None);
+     p->callback = Py_None;
+-    p->response_data = NULL;
+-    p->response_len = 0;
+     Py_INCREF(Py_None);
+     p->user_data = Py_None;
+     
diff --git a/testing/py-pam/PyPAM-0.5.0-return-value.patch b/testing/py-pam/PyPAM-0.5.0-return-value.patch
new file mode 100644
index 000000000000..6e771e9949a3
--- /dev/null
+++ b/testing/py-pam/PyPAM-0.5.0-return-value.patch
@@ -0,0 +1,57 @@
+diff -up PyPAM-0.5.0/PAMmodule.c.retval PyPAM-0.5.0/PAMmodule.c
+--- PyPAM-0.5.0/PAMmodule.c.retval	2012-05-04 21:47:51.000000000 +0200
++++ PyPAM-0.5.0/PAMmodule.c	2012-05-07 09:42:27.690963206 +0200
+@@ -248,7 +248,7 @@ static PyObject * PyPAM_setcred(PyObject
+     result = pam_setcred(_self->pamh, flags);
+     
+     if (result != PAM_SUCCESS) {
+-        PyErr_SetString(PyPAM_Error, "Not authenticated");
++        PyPAM_Err(_self, result);
+         return NULL;
+     }
+ 
+@@ -270,7 +270,7 @@ static PyObject * PyPAM_acct_mgmt(PyObje
+     result = pam_acct_mgmt(_self->pamh, flags);
+     
+     if (result != PAM_SUCCESS) {
+-        PyErr_SetString(PyPAM_Error, "Not authenticated");
++        PyPAM_Err(_self, result);
+         return NULL;
+     }
+ 
+@@ -292,7 +292,7 @@ static PyObject * PyPAM_chauthtok(PyObje
+     result = pam_chauthtok(_self->pamh, flags);
+     
+     if (result != PAM_SUCCESS) {
+-        PyErr_SetString(PyPAM_Error, "Not authenticated");
++        PyPAM_Err(_self, result);
+         return NULL;
+     }
+ 
+@@ -314,7 +314,7 @@ static PyObject * PyPAM_open_session(PyO
+     result = pam_open_session(_self->pamh, flags);
+     
+     if (result != PAM_SUCCESS) {
+-        PyErr_SetString(PyPAM_Error, "Not authenticated");
++        PyPAM_Err(_self, result);
+         return NULL;
+     }
+ 
+@@ -336,7 +336,7 @@ static PyObject * PyPAM_close_session(Py
+     result = pam_close_session(_self->pamh, flags);
+     
+     if (result != PAM_SUCCESS) {
+-        PyErr_SetString(PyPAM_Error, "Not authenticated");
++        PyPAM_Err(_self, result);
+         return NULL;
+     }
+ 
+@@ -433,7 +433,7 @@ static PyObject * PyPAM_putenv(PyObject
+     result = pam_putenv(_self->pamh, val);
+     
+     if (result != PAM_SUCCESS) {
+-        PyErr_SetString(PyPAM_Error, "Not authenticated");
++        PyPAM_Err(_self, result);
+         return NULL;
+     }
+ 
diff --git a/testing/py-pam/PyPAM-python3-support.patch b/testing/py-pam/PyPAM-python3-support.patch
new file mode 100644
index 000000000000..58d414f56b34
--- /dev/null
+++ b/testing/py-pam/PyPAM-python3-support.patch
@@ -0,0 +1,198 @@
+--- a/PAMmodule.c.python3	2014-06-24 11:29:10.958299393 +0200
++++ b/PAMmodule.c	2014-06-24 15:20:02.728118493 +0200
+@@ -15,6 +15,14 @@
+ #include <stdio.h>
+ #include <dlfcn.h>
+ 
++#if PY_MAJOR_VERSION >= 3
++#define IS_PY3K
++#else
++// include bytesobject.h to map PyBytes_* to PyString_*
++#include <bytesobject.h>
++#endif
++
++
+ static PyObject *PyPAM_Error;
+ 
+ typedef struct {
+@@ -28,7 +36,11 @@
+     void                *dlh1, *dlh2;
+ } PyPAMObject;
+ 
++#ifdef IS_PY3K
++static PyTypeObject PyPAMObject_Type;
++#else
+ staticforward PyTypeObject PyPAMObject_Type;
++#endif
+ 
+ static void PyPAM_Err(PyPAMObject *self, int result)
+ {
+@@ -139,7 +151,6 @@
+         return NULL;
+     }
+ 
+-    PyPAMObject_Type.ob_type = &PyType_Type;
+     p = (PyPAMObject *) PyObject_NEW(PyPAMObject, &PyPAMObject_Type);
+ 
+     if (p == NULL)
+@@ -562,35 +573,44 @@
+     PyObject_Del(self);
+ }
+ 
+-static PyObject * PyPAM_getattr(PyPAMObject *self, char *name)
+-{
+-    return Py_FindMethod(PyPAMObject_Methods, (PyObject *) self, name);
+-}
+-
+ static PyObject * PyPAM_repr(PyPAMObject *self)
+ {
+     char                buf[1024];
+     
+     snprintf(buf, 1024, "<pam object, service=\"%s\", user=\"%s\", conv=%p, pamh=%p>",
+         self->service, self->user, self->conv, self->pamh);
+-    return PyString_FromString(buf);
++    return PyBytes_FromString(buf);
+ }
+ 
+ static PyTypeObject PyPAMObject_Type = {
+-    PyObject_HEAD_INIT(0)    /* Must fill in type value later */
+-    0,
+-    "pam",
+-    sizeof(PyPAMObject),
+-    0,
+-    (destructor)PyPAM_dealloc,        /*tp_dealloc*/
+-    0,        /*tp_print*/
+-    (getattrfunc)PyPAM_getattr,        /*tp_getattr*/
+-    0,        /*tp_setattr*/
+-    0,        /*tp_compare*/
+-    (reprfunc)PyPAM_repr,            /*tp_repr*/
+-    0,        /*tp_as_number*/
+-    0,        /*tp_as_sequence*/
+-    0,        /*tp_as_mapping*/
++    PyVarObject_HEAD_INIT(NULL, 0)    /* Must fill in type value later */
++    "pam",                              /* tp_name */
++    sizeof(PyPAMObject),                /* tp_basicsize */
++    0,                                  /* tp_itemsize */
++    (destructor)PyPAM_dealloc,          /* tp_dealloc */
++    0,                                  /* tp_print */
++    0,                                  /* tp_getattr */
++    0,                                  /* tp_setattr */
++    0,                                  /* tp_compare */
++    (reprfunc)PyPAM_repr,               /* tp_repr */
++    0,                                  /* tp_as_number */
++    0,                                  /* tp_as_sequence */
++    0,                                  /* tp_as_mapping */
++    0,                                  /* tp_hash */
++    0,                                  /* tp_call */
++    0,                                  /* tp_str */
++    PyObject_GenericGetAttr,            /* tp_getattro */
++    0,                                  /* tp_setattro */
++    0,                                  /* tp_as_buffer */
++    Py_TPFLAGS_DEFAULT,                 /* tp_flags */
++    "PyPAM",                            /* tp_doc */
++    0,                                  /* tp_traverse */
++    0,                                  /* tp_clear */
++    0,                                  /* tp_richcompare */
++    0,                                  /* tp_weaklistoffset */
++    0,                                  /* tp_iter */
++    0,                                  /* tp_iternext */
++    PyPAMObject_Methods,                /* tp_methods */
+ };
+ 
+ static PyMethodDef PyPAM_Methods[] = {
+@@ -607,7 +627,12 @@
+  */
+ static void insint(PyObject *d, char *name, int value)
+ {
+-    PyObject*        v = PyInt_FromLong((long) value);
++    PyObject*        v;
++#ifdef IS_PY3K
++    v = PyLong_FromLong((long) value);
++#else
++    v = PyInt_FromLong((long) value);
++#endif
+ 
+     if (!v || PyDict_SetItemString(d, name, v))
+         PyErr_Clear();
+@@ -615,19 +640,42 @@
+     Py_XDECREF(v);
+ }
+ 
++#ifdef IS_PY3K
++static struct PyModuleDef pamdef = {
++        PyModuleDef_HEAD_INIT,
++        "PAM",
++        NULL,
++        -1,
++        PyPAM_Methods,
++        NULL,
++        NULL,
++        NULL,
++        NULL
++};
++
++#define INITERROR return NULL
++PyObject *PyInit_PAM(void)
++
++#else
++#define INITERROR return
+ void initPAM(void)
++#endif
+ {
+     PyObject            *m, *d;
+ 
++#ifdef IS_PY3K
++    m = PyModule_Create(&pamdef);
++#else
+     m = Py_InitModule("PAM", PyPAM_Methods);
++#endif
+     d = PyModule_GetDict(m);
+     
+     PyPAM_Error = PyErr_NewException("PAM.error", NULL, NULL);
+     if (PyPAM_Error == NULL)
+-        return;
++        INITERROR;
+     PyDict_SetItemString(d, "error", PyPAM_Error);
+ 
+-    PyPAMObject_Type.ob_type = &PyType_Type;
++    Py_TYPE(&PyPAMObject_Type) = &PyType_Type;
+     PyPAMObject_Type.tp_doc = PyPAMObject_doc;
+     Py_INCREF(&PyPAMObject_Type);
+ 
+@@ -692,4 +740,7 @@
+     insint(d, "PAM_BINARY_PROMPT", PAM_BINARY_PROMPT);
+ #endif
+ 
++#ifdef IS_PY3K
++    return m;
++#endif
+ }
+--- a/setup.py.python3	2014-06-24 15:58:07.792172439 +0200
++++ b/setup.py	2014-06-24 15:58:13.714909021 +0200
+@@ -12,7 +12,7 @@
+     license='LGPL',
+     ext_modules=[
+         Extension(
+-            'PAMmodule',
++            'PAM',
+             ['PAMmodule.c'],
+             libraries=['pam', 'pam_misc'],
+             extra_compile_args = ['-std=c99'],
+--- a/tests/PamTest.py.python3	2014-06-24 16:54:28.902998249 +0200
++++ b/tests/PamTest.py	2014-06-24 17:07:11.392094775 +0200
+@@ -41,13 +41,13 @@
+     def test_userdata_default(self):
+         """The default value for userdata is None."""
+     
+-        self.failUnless(self.pam.get_userdata() is None)
++        self.assertTrue(self.pam.get_userdata() is None)
+ 
+     def test_userdata(self):
+         """The userdata getter and setter will store and return any data."""
+     
+         self.pam.set_userdata(1)
+-        self.failUnless(self.pam.get_userdata() == 1)
++        self.assertTrue(self.pam.get_userdata() == 1)
+ 
+     def test_start(self):
+         """pam.start() works as expected."""
diff --git a/testing/py-pam/pypam-0.5.0-stricter.patch b/testing/py-pam/pypam-0.5.0-stricter.patch
new file mode 100644
index 000000000000..4079f6ff7199
--- /dev/null
+++ b/testing/py-pam/pypam-0.5.0-stricter.patch
@@ -0,0 +1,15 @@
+=== modified file 'PAMmodule.c'
+--- a/PAMmodule.c	2007-05-28 17:50:59 +0000
++++ b/PAMmodule.c	2007-05-28 18:13:33 +0000
+@@ -9,8 +9,9 @@
+ 
++#include <Python.h>
+ #include <security/pam_appl.h>
+ #include <security/pam_misc.h>
+-#include <Python.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <dlfcn.h>
+ 
+ static PyObject *PyPAM_Error;
+
-- 
GitLab