diff --git a/testing/peep/APKBUILD b/testing/peep/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..4477bd630aed43a1be875deb1442dd4873588dc0
--- /dev/null
+++ b/testing/peep/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=peep
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="Text viewer that works like less(1) on small pane within terminal window"
+url="https://github.com/ryochack/peep"
+# riscv64: found textrels
+# s390x: nix crate fails to build
+arch="all !riscv64 !s390x"
+license="MIT"
+makedepends="cargo"
+source="https://github.com/ryochack/peep/archive/v$pkgver/peep-$pkgver.tar.gz
+	regex-features.patch
+	"
+
+export CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
+export CARGO_PROFILE_RELEASE_LTO="true"
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
+export CARGO_PROFILE_RELEASE_PANIC="abort"
+
+prepare() {
+	default_prepare
+
+	cargo fetch --locked
+}
+
+build() {
+	cargo build --frozen --release
+}
+
+check() {
+	cargo test --frozen
+}
+
+package() {
+	install -D -m755 target/release/$pkgname -t "$pkgdir"/usr/bin/
+}
+
+sha512sums="
+2e2d22389fc6c06a95d528e172756d6675244fe36029cdc139c16cd910f2fe6151659bed5d3e1f8d754d6c69d7427e891d2b94444f764324241e4ba3f47eed81  peep-0.1.6.tar.gz
+d99a9de7e2c7bb458e9ada5d7d6fa401860a211021c03f1819484e9f689b116502d7577c09f5c092fe172700ce885de734075b1f93cb523ec22bf2f31beaec42  regex-features.patch
+"
diff --git a/testing/peep/regex-features.patch b/testing/peep/regex-features.patch
new file mode 100644
index 0000000000000000000000000000000000000000..b77913f5964ff89cdaba15e304b64cf02acc2eb5
--- /dev/null
+++ b/testing/peep/regex-features.patch
@@ -0,0 +1,47 @@
+Reduce size of the binary by disabling some rarely used unicode features.
+
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -22 +22 @@
+-regex = "1.5"
++regex = { version = "1.5", default-features = false, features = ["std", "unicode-case", "unicode-gencat", "unicode-perl"] }
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -3,15 +3,6 @@
+ version = 3
+ 
+ [[package]]
+-name = "aho-corasick"
+-version = "0.7.18"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "1e37cfd5e7657ada45f742d6e99ca5788580b5c529dc78faf11ece6dc702656f"
+-dependencies = [
+- "memchr",
+-]
+-
+-[[package]]
+ name = "autocfg"
+ version = "1.1.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+@@ -92,12 +83,6 @@
+ ]
+ 
+ [[package]]
+-name = "memchr"
+-version = "2.5.0"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "2dffe52ecf27772e601905b7522cb4ef790d2cc203488bbd0e2fe85fcb74566d"
+-
+-[[package]]
+ name = "memoffset"
+ version = "0.6.5"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+@@ -182,8 +167,6 @@
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "d83f127d94bdbcda4c8cc2e50f6f84f4b611f69c902699ca385a39c3a75f9ff1"
+ dependencies = [
+- "aho-corasick",
+- "memchr",
+  "regex-syntax",
+ ]
+