diff --git a/community/asfa/APKBUILD b/community/asfa/APKBUILD
index 3ca95faf0d76a62fefb5690c3ca03016b2ff1629..59e6f7e3cc284271d1ad7038513cf8d42aed3a84 100644
--- a/community/asfa/APKBUILD
+++ b/community/asfa/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=asfa
-pkgver=0.9.1
-pkgrel=3
+pkgver=0.10.0
+pkgrel=0
 pkgdesc="Share files by uploading via SSH and generating a non-guessable link"
 url="https://github.com/obreitwi/asfa"
 # s390x: build failure
@@ -13,11 +13,9 @@ makedepends="
 	cargo
 	cargo-auditable
 	libssh2-dev
-	openssl-dev>3
-	"
-source="https://github.com/obreitwi/asfa/archive/v$pkgver/asfa-$pkgver.tar.gz
-	strip-regex-features.patch
+	openssl-dev
 	"
+source="https://github.com/obreitwi/asfa/archive/v$pkgver/asfa-$pkgver.tar.gz"
 options="!check"  # tests use docker
 
 export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
@@ -39,6 +37,5 @@ package() {
 }
 
 sha512sums="
-ca42518793cb5c11e1ffc18066a0ee954dcba76a20b595ec17ba71ecff7e5a6967d8e5178ec3c8c93ae8a539ecd99f55ea5877680f21856be73391f47f59ac52  asfa-0.9.1.tar.gz
-e3590cd7dc8a340d9bf8e63fca5bb252075e6dc8825ac510d0cfb088a4c0dcd65a65e2016a3409a1b95136aabadc4e5397e71413414ea9ad532d7a2f898c555d  strip-regex-features.patch
+bbbdab8d9c719637f75e6100cd6a8176a78bad7ae25530f550ec0aba8dd4edfc94862dddbf10a17cdacc06a5e634bb36d7142f84353a4dc2ae2778526180200d  asfa-0.10.0.tar.gz
 "
diff --git a/community/asfa/strip-regex-features.patch b/community/asfa/strip-regex-features.patch
deleted file mode 100644
index 66e14d7abc79b31736f7c096a7a88e7a7aeceb8a..0000000000000000000000000000000000000000
--- a/community/asfa/strip-regex-features.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Patch-Source: https://github.com/obreitwi/asfa/pull/14 (modified)
---
-From 14e67b80d2253c58d4a9d03fafbc09785038c04d Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Tue, 5 Jul 2022 00:20:38 +0200
-Subject: [PATCH] Disable unnecessary regex features to reduce binary size by ~20%
-
----
- Cargo.lock | 11 -----------
- Cargo.toml |  2 +-
- 2 files changed, 1 insertion(+), 12 deletions(-)
-
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -18,15 +18,6 @@
- checksum = "f26201604c87b1e01bd3d98f8d5d9a8fcbb815e8cedb41ffccbeb4bf593a35fe"
- 
- [[package]]
--name = "aho-corasick"
--version = "0.7.18"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "1e37cfd5e7657ada45f742d6e99ca5788580b5c529dc78faf11ece6dc702656f"
--dependencies = [
-- "memchr",
--]
--
--[[package]]
- name = "anyhow"
- version = "1.0.51"
- source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -775,8 +766,6 @@
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "d07a8629359eb56f1e2fb1652bb04212c072a87ba68546a04065d525673ac461"
- dependencies = [
-- "aho-corasick",
-- "memchr",
-  "regex-syntax",
- ]
- 
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -31,7 +31,7 @@
- lazy_static = "1.4.0"
- log = "0.4.14"
- percent-encoding = "2.1.0"
--regex = "1.5.4"
-+regex = { version = "1.5.4", default-features = false, features = ["std", "unicode-bool", "unicode-perl"] }
- rpassword = "5.0.1"
- sha2= "0.10.0"
- simple_logger = { version = "1.16.0", default-features = false, features = ["threads", "colors"]}