From 60a3b918ee287be9eb1e2d8b804548f20de64c19 Mon Sep 17 00:00:00 2001
From: Celeste <20312-Celeste@users.gitlab.alpinelinux.org>
Date: Thu, 2 Nov 2023 13:05:35 +0000
Subject: [PATCH] community/nemo-qml-plugin-systemsettings: fix lfs64 usage

---
 .../0004-Fix-musl-lfs64.patch                       | 13 +++++++++++++
 community/nemo-qml-plugin-systemsettings/APKBUILD   |  4 +++-
 2 files changed, 16 insertions(+), 1 deletion(-)
 create mode 100644 community/nemo-qml-plugin-systemsettings/0004-Fix-musl-lfs64.patch

diff --git a/community/nemo-qml-plugin-systemsettings/0004-Fix-musl-lfs64.patch b/community/nemo-qml-plugin-systemsettings/0004-Fix-musl-lfs64.patch
new file mode 100644
index 000000000000..f61cf6924d9a
--- /dev/null
+++ b/community/nemo-qml-plugin-systemsettings/0004-Fix-musl-lfs64.patch
@@ -0,0 +1,13 @@
+--- a/src/partitionmanager.cpp
++++ b/src/partitionmanager.cpp
+@@ -285,8 +285,8 @@
+                     && quota.dqb_bsoftlimit != 0)
+                 quotaAvailable = std::max((qint64)dbtob(quota.dqb_bsoftlimit) - (qint64)quota.dqb_curspace, 0LL);
+ 
+-            struct statvfs64 stat;
+-            if (::statvfs64(partition->mountPath.toUtf8().constData(), &stat) == 0) {
++            struct statvfs stat;
++            if (::statvfs(partition->mountPath.toUtf8().constData(), &stat) == 0) {
+                 partition->bytesTotal = stat.f_blocks * stat.f_frsize;
+                 qint64 bytesFree = stat.f_bfree * stat.f_frsize;
+                 qint64 bytesAvailable = std::min((qint64)(stat.f_bavail * stat.f_frsize), quotaAvailable);
diff --git a/community/nemo-qml-plugin-systemsettings/APKBUILD b/community/nemo-qml-plugin-systemsettings/APKBUILD
index 2b9bcab4c638..db2f456f9695 100644
--- a/community/nemo-qml-plugin-systemsettings/APKBUILD
+++ b/community/nemo-qml-plugin-systemsettings/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=nemo-qml-plugin-systemsettings
 pkgver=0.5.82
-pkgrel=2
+pkgrel=3
 pkgdesc="Nemo QML systemsettings plugin"
 url="https://github.com/sailfishos/nemo-qml-plugin-systemsettings"
 arch="all !armhf" # missing dependencies
@@ -34,6 +34,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/sailfishos/nemo-qml-plugin-s
 	0001-Remove-developer-mode.patch
 	0002-Remove-packagekit-usage.patch
 	0003-Include-linux-quota.h.patch
+	0004-Fix-musl-lfs64.patch
 	"
 
 build() {
@@ -53,4 +54,5 @@ sha512sums="
 4a34709e3a3fa14e53a79d767d5bd442aecdda8c67f54d6a6546fa792385043c1aaf3cf3f68ef6bc099cb354bb1503d3653ed974d5a9db7ab7e62591916ee933  0001-Remove-developer-mode.patch
 e00c3d0ccaf9ceffbd4006c008bbd71c286998590640830c0f8997e0f292f40bc5837b57070701170198a645b756cfb87e74cc570b8554aba6f7c1ade5276a2a  0002-Remove-packagekit-usage.patch
 561741fb4f83656ac5d26e979033991347280e6e90f0ef0dc043318fdaf62f136673039dfac1b1af2bf94322f761525725d43aa2d345b7a8599d992f150800ae  0003-Include-linux-quota.h.patch
+4aafdc5788eb78625f754ec6a30c5520d265d0c52632175ddf78d5f127aef0c62d060347bc1e490881e2552417ba90717672157bdae4e40c3328ecff0def090d  0004-Fix-musl-lfs64.patch
 "
-- 
GitLab