diff --git a/testing/ocaml-fileutils/APKBUILD b/testing/ocaml-fileutils/APKBUILD
index 931dd6f54ffd0c14ebf4c7c1b0a237cc2e4cf22a..a7f2b6fcc9bc2a567ef61713cdf96616cb36a25d 100644
--- a/testing/ocaml-fileutils/APKBUILD
+++ b/testing/ocaml-fileutils/APKBUILD
@@ -1,31 +1,32 @@
 # Contributor: Fernando Casas Schossow <casasfernando@outlook.com>
 # Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
 pkgname=ocaml-fileutils
-pkgver=0.4.4
+pkgver=0.6.3
 pkgrel=0
 pkgdesc="OCaml library for common file and filename operations"
 url="https://github.com/gildor478/ocaml-fileutils"
-arch="aarch64 ppc64le x86_64"
+arch="all !mips64 !riscv64" # limited by ocaml aport
 license="LGPL-2.1-or-later-WITH-linking-exception"
 makedepends="ocaml ocaml-ocamldoc ocaml-ounit-dev ocamlbuild ocaml-compiler-libs ocaml-findlib-dev"
 subpackages="$pkgname-dev $pkgname-doc"
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/gildor478/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gildor478/ocaml-fileutils/archive/$pkgver.tar.gz"
+
+# 32bit archs
+case "$CARCH" in
+    arm*|x86) options="$options textrels" ;;
+esac
 
 build() {
-	cd "$builddir"
 	export OCAMLPARAM="safe-string=0,_"
 	ocaml setup.ml -configure --prefix /usr --destdir "$pkgdir"
 	make
 }
 
 check() {
-	cd "$builddir"
 	make test
 }
 
 package() {
-	cd "$builddir"
 	export DESTDIR="$pkgdir"
 	export OCAMLFIND_DESTDIR="$DESTDIR/usr/lib/ocaml"
 	mkdir -p "$OCAMLFIND_DESTDIR" "$OCAMLFIND_DESTDIR/stublibs"
@@ -33,4 +34,4 @@ package() {
 	install -D -m644 COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/COPYING.txt"
 }
 
-sha512sums="35aa175ae8a024fe6719716cfa6769a72d8e36fc3dd743da12c9037aa52a1699b12462ab78f1341fb5f2ca25e7935d73b9fb3648161d88771f8d35f7480126f7  ocaml-fileutils-0.4.4.tar.gz"
+sha512sums="491c01347714b9caf69e184be7e031d82d3602b91ce52c5c995b25897090d9af79b2ae058ff92b91ab31b44dd1fdf15fbe1a428d2f3a50872d3f0f7689a64e8c  ocaml-fileutils-0.6.3.tar.gz"