diff --git a/community/perl-sys-cpu/APKBUILD b/community/perl-sys-cpu/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..86d870cd884d9e6ae6f5e0a9e680052fa5eea5d9
--- /dev/null
+++ b/community/perl-sys-cpu/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Maintainer: psykose <alice@ayaya.dev>
+pkgname=perl-sys-cpu
+pkgver=0.61
+pkgrel=0
+pkgdesc="Perl extension for getting CPU information"
+url="https://metacpan.org/release/HTTP-Message/"
+arch="all"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/M/MZ/MZSANFORD/Sys-CPU-$pkgver.tar.gz
+	unistd.patch
+	"
+builddir="$srcdir/Sys-CPU-$pkgver"
+
+build() {
+	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+	PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+	make
+}
+
+check() {
+	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+	make test
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+391e113c87d9044cd43c47f9f78a782fab65566a32c028c01f7f3335a5065b6755586ea3143356510c8d28a7d1ad572cc6203ec189eaaa379967bdbd0a0bd7bc  Sys-CPU-0.61.tar.gz
+9ae2b76b389e65fdd4331bb97be3e2d7409fa217d53114c8ee00c258d6dde194b1d13981fce0cd0b6d6b7e6fefce9b9527128b75eac043de200e0671e4b6f34a  unistd.patch
+"
diff --git a/community/perl-sys-cpu/unistd.patch b/community/perl-sys-cpu/unistd.patch
new file mode 100644
index 0000000000000000000000000000000000000000..a8fab247ed78d0513e5ed163814eb8b404e0faf0
--- /dev/null
+++ b/community/perl-sys-cpu/unistd.patch
@@ -0,0 +1,12 @@
+diff --git a/CPU.xs b/CPU.xs
+index 236b14d..98f1c79 100644
+--- a/CPU.xs
++++ b/CPU.xs
+@@ -24,7 +24,6 @@
+  #include <winreg.h>
+ #else                /* other (try unix) */
+  #include <unistd.h>
+- #include <sys/unistd.h>
+ #endif
+ #if defined(__sun) || defined(__sun__)
+  #include <sys/processor.h>