diff --git a/community/bupstash/APKBUILD b/community/bupstash/APKBUILD
index 7642d4eba89965acd4dbe4f4f69210dfceebee21..50e512fabc540168f26d4b5c64895ff09ed98b45 100644
--- a/community/bupstash/APKBUILD
+++ b/community/bupstash/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer:
+# Maintainer: Pedro Lucas Porcellis <porcellis@eletrotupi.com>
 pkgname=bupstash
 pkgver=0.12.0
-pkgrel=3
+pkgrel=4
 pkgdesc="Easy and efficient encrypted backups"
 url="https://bupstash.io/"
 # armhf,armv7,x86: sodium bindgen test fails
@@ -21,6 +21,7 @@ options="net"
 source="$pkgname-$pkgver.tar.gz::https://github.com/andrewchambers/bupstash/archive/v$pkgver.tar.gz
 	regex-features.patch
 	unbundle-sqlite.patch
+	libc-crate-update.patch
 	"
 
 _cargo_opts="--no-default-features --frozen"
@@ -58,4 +59,5 @@ sha512sums="
 a1fb8af217dcca4322bceb6286379096586c0b7359d7e794d8f8b2890dc2a3ee8cc8baace15b42a3466dedc83ed12443bb24931d817cb06702e62f5e46ff33f8  bupstash-0.12.0.tar.gz
 c10c8dd9ddd17d53a730da07d2eb1595e9924ed4ec50aaf55db30e197f8cc77ca76194bfb4a04808db4be53789ba2eead3b0a23625e662911e38cb82ca730b34  regex-features.patch
 9963dee4793d2c365ad05d0141dd7b28ddb4098d1b9b60561d6f3f05401dbdbb581b6a89e0d63ec0f5167a4e8478390eff6e3380581867d1dfe0ed2074449870  unbundle-sqlite.patch
+781d2a8e8fb1776f40af20eecab0f64b1158fa1c989a0bc8e7df8b4f9a35ec8d925188f1d723b31495ed7aa228303b45b9c29320517041c3fba2e06d278ff029  libc-crate-update.patch
 "
diff --git a/community/bupstash/libc-crate-update.patch b/community/bupstash/libc-crate-update.patch
new file mode 100644
index 0000000000000000000000000000000000000000..a3605f72de279a110e43f6428569f6ba853fe07c
--- /dev/null
+++ b/community/bupstash/libc-crate-update.patch
@@ -0,0 +1,28 @@
+From b5ac70513d29a00bf46f4bac82ff5a874bc96ef6 Mon Sep 17 00:00:00 2001
+From: Pedro Lucas Porcellis <porcellis@eletrotupi.com>
+Date: Wed, 16 Aug 2023 12:18:32 -0300
+Subject: [PATCH] Update libc to the latest version
+
+---
+ Cargo.lock | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index e4a2dac..45e1f5f 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -432,9 +432,9 @@ checksum = "e2abad23fbc42b3700f2f279844dc832adb2b2eb069b2df918f455c4e18cc646"
+ 
+ [[package]]
+ name = "libc"
+-version = "0.2.120"
++version = "0.2.147"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "ad5c14e80759d0939d013e6ca49930e59fc53dd8e5009132f76240c179380c09"
++checksum = "b4668fb0ea861c1df094127ac5f1da3409a82116a4ba74fca2e58ef927159bb3"
+ 
+ [[package]]
+ name = "libsqlite3-sys"
+-- 
+2.41.0
+
diff --git a/community/prometheus/APKBUILD b/community/prometheus/APKBUILD
index 8e38a434fc766c42c4627ae61735818a842ba4ad..03c06f7e33c98567a6b37c5a04364dcbe7b1aec7 100644
--- a/community/prometheus/APKBUILD
+++ b/community/prometheus/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Pedro Lucas Porcellis <porcellis@eletrotupi.com>
 pkgname=prometheus
 pkgver=2.45.0
-pkgrel=2
+pkgrel=3
 pkgdesc="The Prometheus monitoring system and time series database"
 url="https://github.com/prometheus/prometheus"
 arch="all !riscv64" # npm
diff --git a/community/solvespace/APKBUILD b/community/solvespace/APKBUILD
index eeadca1a046606a5aa0fc5841bef694211c2ceaa..4cebb1cd49ba5d19e1d6c8f434cca2f7285f10d9 100644
--- a/community/solvespace/APKBUILD
+++ b/community/solvespace/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Pedro Lucas Porcellis <porcellis@eletrotupi.com>
 pkgname=solvespace
 pkgver=3.1
-pkgrel=0
+pkgrel=1
 _dxtlibver=0b7b7b709d9299565db603f878214656ef5e9ddf
 _solvespace_commit=70bde63cb32a7f049fa56cbdf924e2695fcb2916
 _mimalloc_commit=f819dbb4e4813fab464aee16770f39f11476bfea
diff --git a/community/sshign/APKBUILD b/community/sshign/APKBUILD
index fcd61a31bbdc10b98702f663f839d7b1e325e4dd..fad97529062b7d39a14443487579d4d9eb2abdab 100644
--- a/community/sshign/APKBUILD
+++ b/community/sshign/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Pedro Lucas Porcellis <porcellis@eletrotupi.com>
 pkgname=sshign
 pkgver=0.2.1
-pkgrel=18
+pkgrel=19
 pkgdesc="Small program to sign & verify files with your SSH key"
 url="https://git.sr.ht/~minus/sshign"
 arch="all"
diff --git a/testing/chathistorysync/APKBUILD b/testing/chathistorysync/APKBUILD
index 9179da81e82c9baff05005801856e588ea8e8d6e..422aa0378e5d31ca2ecec9134e3de5c88c8c8a6c 100644
--- a/testing/chathistorysync/APKBUILD
+++ b/testing/chathistorysync/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Pedro Lucas Porcellis <porcellis@eletrotupi.com>
 pkgname=chathistorysync
 pkgver=0.2.0
-pkgrel=9
+pkgrel=10
 pkgdesc="A tool for syncing IRC logs via the CHATHISTORY extension"
 url="https://sr.ht/~emersion/chathistorysync"
 arch="all"