diff --git a/testing/next/APKBUILD b/testing/nyxt/APKBUILD
similarity index 55%
rename from testing/next/APKBUILD
rename to testing/nyxt/APKBUILD
index 7271bc87a320102b991cd99f76e8cec3e3c172c5..d1a1aef9f56926295becbd22f1fc1eb7cf295a15 100644
--- a/testing/next/APKBUILD
+++ b/testing/nyxt/APKBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Will Sinatra <wpsinatra@gmail.com>
 # Contributor: Will Sinatra <wpsinatra@gmail.com>
 # Contributor: Benjamin Buccianti <bebuccianti@gmail.com>
-pkgname=next
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+pkgname=nyxt
 pkgver=1.5.0
 pkgrel=0
-pkgdesc="Atlas Engineer Next Browser"
-url="https://next.atlas.engineer"
-arch="x86_64 aarch64"
+pkgdesc="Atlas Engineer Nyxt Browser"
+url="https://nyxt.atlas.engineer"
+arch="x86 x86_64 aarch64"
+#SBCL must be compiled with thread support for Nyxt to work
+#SBCL thread is not supported on armv7
+#SBCL is only built on arches x86, x86_64, aarch64, and armv7
 license="BSD-3-Clause"
-source="$pkgname-$pkgver.zip::https://github.com/atlas-engineer/next/archive/$pkgver.zip"
+source="$pkgname-$pkgver.zip::https://github.com/atlas-engineer/nyxt/archive/$pkgver.zip"
 makedepends="git sbcl webkit2gtk-dev"
 depends="webkit2gtk glib-networking gsettings-desktop-schemas libfixposix libfixposix-dev gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-plugins-ugly libffi libffi-dev"
 options="!check !strip" #No testsuite exists; Stripping the package causes the
-# package to build, but the next browser is unfunctional, dropping to an SBCL repl
+# package to build, but the nyxt browser is unfunctional, dropping to an SBCL repl
 # instead of properly running.
 
+replaces=next
+provides=next=$pkgver-r$pkgrel
+
 build() {
 	make all
 }
@@ -23,4 +29,4 @@ package() {
 	make PREFIX=/usr DESTDIR="$pkgdir" install
 }
 
-sha512sums="b481da4000ff7d4e15e647e56df2693ae1fffb8b7b4f49a529277afd8b1068aa23d08c01a59a6f0c78adde3e4540c3f971b56c8228ce5bc7c69dac7681f32a3b  next-1.5.0.zip"
+sha512sums="1d27e2a2b1f586ea2904d51205bceaa3b7ac3107e5b1135c0f6be54dd2d3bf82aec69fc01a56eed64b9540364971b4638aa873cbd4ed37c11dfa25cfdf195c27  nyxt-1.5.0.zip"