diff --git a/community/althttpd/10-allow-filename-plus-sign.patch b/community/althttpd/10-allow-filename-plus-sign.patch
index 44dd2be66a66b92ed37589d3ad1b8cf4df4fd419..ba9228fdf6aa4fb682e3f2c37bfef081b63f62f2 100644
--- a/community/althttpd/10-allow-filename-plus-sign.patch
+++ b/community/althttpd/10-allow-filename-plus-sign.patch
@@ -4,7 +4,7 @@ adds the plus sign (0x2b) to the list of characters allowed by upstream
 which are 0-9a-zA-Z,-./:_~
 --- src/althttpd.c.orig
 +++ src/althttpd.c
-@@ -1632,7 +1632,7 @@
+@@ -1827,7 +1827,7 @@
        /*  x0  x1  x2  x3  x4  x5  x6  x7  x8  x9  xa  xb  xc  xd  xe  xf */
  /* 0x */   0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,
  /* 1x */   0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,
diff --git a/community/althttpd/APKBUILD b/community/althttpd/APKBUILD
index c7e1b90bce518099a458c6254c36c15926d9b98d..62de88e3cf2195493e892632d8c49a562608ec60 100644
--- a/community/althttpd/APKBUILD
+++ b/community/althttpd/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Sodface <sod@sodface.com>
 # Maintainer: Sodface <sod@sodface.com>
 pkgname=althttpd
-pkgver=202203201558
+pkgver=202203261203
 pkgrel=0
 pkgdesc="Small, simple, stand-alone HTTP server"
 url="https://sqlite.org/althttpd/doc/trunk/althttpd.md"
@@ -34,8 +34,8 @@ package() {
 }
 
 sha512sums="
-a611272339d29a95ca80cfeefabb391b8f69e8e13582ccd86763af8aa6b66f1f409b5d84fe6f65f35a7e54cfbd6f336acf195865e5ca02ad4b56734dd8971370  althttpd-202203201558.tar.gz
-2ae6bb952a1d6e4e7b7f78c09e91d5b0fcf9b520dd6305c282f36c7e2e2c0280020947a3ce5fc0fb2961fc2db3689421b1ad81a1fe31ae5f4a0a0c0878bb7bfc  10-allow-filename-plus-sign.patch
-6bee7c54a75782d2112956e85b7105ddf47189d7c8b9f5a8609e6d20813ecba0e3331f85734faf350d6279bcc988ca2d34091cbcf98807b79564fa38e3ce4a29  althttpd.confd
+179e3baa82b01a032eaf5b48c24e62236aa9d0865eb073cbedf64dd04a481e4b6988c0280929172a277d0de8ba8caf7c5c309c8d27babc8d97b83b53759d1210  althttpd-202203261203.tar.gz
+37b5c394b33c3b5e0ff93ae951610bf86ecbf877ae5b267d25c6f188cf60c853220399f8f87f119c0f6f6513e8a82d21e5643d08631aa0702e704554b803ced3  10-allow-filename-plus-sign.patch
+4418cd6431dccc2a51866d0a6b486166de4ea4752fcdadd41b2605ac7f4fbc49af076cc48ef1cafb38dfceef22c4e1cabd4b160ec2e2f4871b39c33680440a5b  althttpd.confd
 f21867430470b836d97d60215d9dda835125140cced3bb9c856349228572f2c73ac0574d3f705d72938879fc2b5a37855768a5f7de5c29943e3aa6ead5d72d9c  althttpd.initd
 "
diff --git a/community/althttpd/althttpd.confd b/community/althttpd/althttpd.confd
index f222185a5ba71d2361bb5effd22cce0f0bbf7516..81b67e058240551fcee2e863a3efaa9520f2b925 100644
--- a/community/althttpd/althttpd.confd
+++ b/community/althttpd/althttpd.confd
@@ -23,6 +23,17 @@
 #**                   FILE name is expanded using strftime() if it contains
 #**                   at least one '%' and is not too long.
 #**
+#**  --ipshun DIR     If the remote IP address is also the name of a file
+#**                   in DIR that has size N bytes and where either N is zero
+#**                   or the m-time of the file is less than N time-units ago
+#**                   then that IP address is being shunned and no requests
+#**                   are processed.  The time-unit is a compile-time option
+#**                   (BANISH_TIME) that defaults to 300 seconds.  If this
+#**                   happens, the client gets a 503 Service Unavailable
+#**                   reply. Furthermore, althttpd will create ip-shunning
+#**                   files following a 404 Not Found error if the request
+#**                   URI is an obvious hack attempt.
+#**
 #**  --https BOOLEAN  Indicates that input is coming over SSL and is being
 #**                   decoded upstream, perhaps by stunnel. This option
 #**                   does *not* activate built-in TLS support.  Use --cert