From 59c863da1caa90fc459ff6536f41bb54539eb7a3 Mon Sep 17 00:00:00 2001
From: Bart Ribbers <bribbers@disroot.org>
Date: Sat, 28 Mar 2020 18:09:53 +0100
Subject: [PATCH] testing/py3-testfixtures: new aport

---
 testing/py3-testfixtures/APKBUILD | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/py3-testfixtures/APKBUILD

diff --git a/testing/py3-testfixtures/APKBUILD b/testing/py3-testfixtures/APKBUILD
new file mode 100644
index 000000000000..56ca28209378
--- /dev/null
+++ b/testing/py3-testfixtures/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-testfixtures
+pkgver=6.14.1
+pkgrel=0
+pkgdesc="A collection of helpers and mock objects for unit tests and doc tests"
+url="https://github.com/Simplistix/testfixtures"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools py3-sphinx"
+checkdepends="py3-pytest py3-sybil"
+source="https://pypi.python.org/packages/source/t/testfixtures/testfixtures-$pkgver.tar.gz"
+options="!check" # Broken tests https://github.com/Simplistix/testfixtures/issues/134
+builddir="$srcdir/testfixtures-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	PYTHONPATH="$PWD/build/lib" pytest
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0da31d5e382984c22ada846c07570d4a179ba819005dd29891e551b99190fabaaf17174456f7ed4864e9c4aa25f7d5d8b86aa123b4628328610d6930c9c5d6bd  testfixtures-6.14.1.tar.gz"
-- 
GitLab