diff --git a/community/iotop/APKBUILD b/community/iotop/APKBUILD
index 79930c5879919476bfbd5666efe7381ab867de7a..43557a0a22aa6d7dd83be47ef1c71abdb512315a 100644
--- a/community/iotop/APKBUILD
+++ b/community/iotop/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
 pkgname=iotop
 pkgver=0.6
-pkgrel=8
+pkgrel=9
 # source tarballs are gone now using git repo - commit's first 7 chars
 _commit=59e2537
 pkgdesc="I/O monitoring tool"
diff --git a/community/iotop/iotop.pre-upgrade b/community/iotop/iotop.pre-upgrade
index c0bb0578905a54d86507f4d9bbedea5affcce942..0e9ba710359e1336aafa4d9357ed80385bbb58c6 100644
--- a/community/iotop/iotop.pre-upgrade
+++ b/community/iotop/iotop.pre-upgrade
@@ -2,10 +2,10 @@
 
 ver_old=$2
 
-if [ "$(apk version -t "$ver_old" '0.6-r8')" = '<' ]; then
+if [ "$(apk version -t "$ver_old" '0.6-r9')" = '<' ]; then
    # .egg-info was changed from a file to a directory, so we have to remove it
    # see https://gitlab.alpinelinux.org/alpine/apk-tools/-/issues/10856
-   rm -f usr/lib/python3.10/site-packages/iotop-0.6-py3.10.egg-info >/dev/null 2>&1
+   rm -f /usr/lib/python3.10/site-packages/iotop-0.6-py3.10.egg-info >/dev/null 2>&1
 fi
 
 exit 0