diff --git a/community/gitlab-runner/APKBUILD b/community/gitlab-runner/APKBUILD
index cbce7c511a9a3b7c115a6108ce28f2c7d30bd7ee..3545e6616a06ea48edfdcc173ae4292c053c8385 100644
--- a/community/gitlab-runner/APKBUILD
+++ b/community/gitlab-runner/APKBUILD
@@ -2,13 +2,13 @@
 # Contributor: Rasmus Thomsen <oss@cogitir.dev>
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=gitlab-runner
-pkgver=13.10.0
-pkgrel=2
+pkgver=13.12.0
+pkgrel=0
 # first 8 chars of the git hash of the release, see
 # https://gitlab.com/gitlab-org/gitlab-runner/-/tags
 # PLEASE update this, since they're used to determine what version of
 # https://hub.docker.com/r/gitlab/gitlab-runner-helper/tags to use
-_rev=54944146
+_rev=7a6612da
 pkgdesc="GitLab runner for CI/CD jobs"
 url="https://docs.gitlab.com/runner/"
 arch="all"
@@ -69,11 +69,8 @@ helper() {
 }
 
 sha512sums="
-7920f77e25a308036146fbbdf6ddd1041e65837d3c450c21691ef9bbee06bcff017aa7cf64b55770c55003296317137df75227e18a113d53afb02d1c5f15f33d  gitlab-runner-v13.10.0.tar.gz
+d1b4ea21c81671cd7da61020d7cd24889a844387e6e86b265a25497ca47b83ab95cc91fd153d8078ad74c15f3be525f6b3d7ec83f544bf7487633ae9de9e137f  gitlab-runner-v13.12.0.tar.gz
 2ae753efc220c46378e84831f01b289f3689af70cd7cbb0bbcc04dc17c910d65eb5105c198d5a23098e27797a7d1c695f49b244993ea4676eb9ec9cda064f44e  gitlab-runner.initd
 243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445  gitlab-runner.confd
+eaaec01ad687b955e83f2c475e865a0c8a93aea23f8f0c88c0088461e8b8050b5423e03683149f917c71ff2520ea04a0c3af1267b946efb34c0a70670fa27bc2  update-pty-for-riscv64.patch
 "
-sha512sums="7920f77e25a308036146fbbdf6ddd1041e65837d3c450c21691ef9bbee06bcff017aa7cf64b55770c55003296317137df75227e18a113d53afb02d1c5f15f33d  gitlab-runner-v13.10.0.tar.gz
-2ae753efc220c46378e84831f01b289f3689af70cd7cbb0bbcc04dc17c910d65eb5105c198d5a23098e27797a7d1c695f49b244993ea4676eb9ec9cda064f44e  gitlab-runner.initd
-243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445  gitlab-runner.confd
-d4256cae06280fa02c24b588b9ee1ffc2a9810acb68a8105d4ccfe22068cfb963b679c22b8f0274df01402a16125b66bf2c1698277f31e8fb2d7184eb01a6ab8  update-pty-for-riscv64.patch"
diff --git a/community/gitlab-runner/update-pty-for-riscv64.patch b/community/gitlab-runner/update-pty-for-riscv64.patch
index 5572194a69655b034d61345b5041c6cfd5f8c654..48c244879f744fc4da0cb6dc7ed4c803b449e9a2 100644
--- a/community/gitlab-runner/update-pty-for-riscv64.patch
+++ b/community/gitlab-runner/update-pty-for-riscv64.patch
@@ -1,17 +1,17 @@
 see: https://gitlab.com/gitlab-org/gitlab-runner/-/issues/27562
 
 diff --git a/go.mod b/go.mod
-index 29993ec72..c5544c813 100644
+index 5969f40..5159a38 100644
 --- a/go.mod
 +++ b/go.mod
-@@ -80,3 +80,5 @@ require (
+@@ -79,3 +79,5 @@ require (
  )
  
  replace golang.org/x/sys => golang.org/x/sys v0.0.0-20200826173525-f9321e4c35a6
 +
 +replace github.com/kr/pty v1.1.1 => github.com/creack/pty v1.1.13
 diff --git a/go.sum b/go.sum
-index 64f3ad41b..59a77c691 100644
+index 074287b..6351c83 100644
 --- a/go.sum
 +++ b/go.sum
 @@ -128,6 +128,8 @@ github.com/containerd/containerd v1.4.3 h1:ijQT13JedHSHrQGWFcGEwzcNKrAGIiZ+jSD5Q
@@ -20,6 +20,6 @@ index 64f3ad41b..59a77c691 100644
  github.com/creack/pty v1.1.11/go.mod h1:oKZEueFk5CKHvIhNR5MUki03XCEU+Q6VDXinZuGJ33E=
 +github.com/creack/pty v1.1.13 h1:rTPnd/xocYRjutMfqide2zle1u96upp1gm6eUHKi7us=
 +github.com/creack/pty v1.1.13/go.mod h1:MOBLtS5ELjhRRrroQr9kyvTxUAFNvYEK993ew/Vr4O4=
- github.com/davecgh/go-spew v0.0.0-20161028175848-04cdfd42973b/go.mod h1:J7Y8YcW2NihsgmVo/mv3lAwl/skON4iLHjSsI+c5H38=
  github.com/davecgh/go-spew v1.1.0/go.mod h1:J7Y8YcW2NihsgmVo/mv3lAwl/skON4iLHjSsI+c5H38=
  github.com/davecgh/go-spew v1.1.1 h1:vj9j/u1bqnvCEfJOwUhtlOARqs3+rkHYY13jYWTU97c=
+ github.com/davecgh/go-spew v1.1.1/go.mod h1:J7Y8YcW2NihsgmVo/mv3lAwl/skON4iLHjSsI+c5H38=