diff --git a/community/iwd/APKBUILD b/community/iwd/APKBUILD
index ca5ed70e98a87a6d0d9349b9c48134736eb60a03..24a19f4e4eb9783e6beaae761af16ae8b5c0f2d0 100644
--- a/community/iwd/APKBUILD
+++ b/community/iwd/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Milan P. Stanić <mps@arvanta.net>
 pkgname=iwd
 pkgver=1.29
-pkgrel=0
+pkgrel=1
 pkgdesc="Internet Wireless Daemon"
 url="https://iwd.wiki.kernel.org/"
 arch="all"
@@ -78,9 +78,9 @@ ead_openrc() {
 
 sha512sums="
 19f5871f63b29da0067fbc55f6691112ccd9aa0107f581d15b0479254c08f6e993c46a01a3b7aefa89a1e48c80ac916b4e515f063c7a5b11f17768f039a41d51  iwd-1.29.tar.gz
-6db0cd6350eeb1e594290b87329a813651db6ae93f5cd917e26a6f1612f3df2e7f2c82779ef897a1c9b491d328d7059283761e4728f7830308cac37cc6e5cdc3  iwd.initd
-e940b1b5f122f1eb2b7e53d3b56d2b74139922941b429aa92778ed54d856d770e280c06fdda192aa49c2b6e7d69723ffec59b2839f7cea1b08b1e7a2d336636f  iwd.confd
-509401a385476b2491f175893013093217351409729ebf3746b8c4cb33c5b6c812fd5ca3d85881a520ad40696c414dfb3a0b585b5dd937c9437142677dc49492  ead.initd
-c44abe2943b7befea0afa2bad55cc022078c2c3103bb99028a5f0e9210ecb9c7b746b339fc15ab866ee8664ccc2c226e2776eeb8e4288da83cb7427adf7a6cd2  ead.confd
+48fb5b5f0b4566a530bf971bcf7ec56ad155340b7d7b73d4e362a73d0395f516c1cd4f13cdf08af8b8b4d4972cbb7ef9b0594a74af474dc1ac949967e116f6fb  iwd.initd
+c53bfe1b18f0e965d6055e79b40d9f01d13648a4ae6124d2bcb0c6a77dc16f96980df0127c67cecd2a0319a6052f980400bb063d00c87ec016ccb350e3fe797e  iwd.confd
+8207a411d400bc7932829c959251a3246d1c33d342afa7070023dc90403e58b19518b2c84fe36495075a44724e2deab38970a2cc1f83bfff5abf3dff54b8ea3f  ead.initd
+4611df202e07178556d61f5642ea82f56cafaee9bf122240d8de8b4937b6bd3458ee7c2d209211523febab942dee184e94c899a1fd4456f8357347030c943c49  ead.confd
 09f4097e653cfecfa1e4bc7b4843832785d0a8ef2a8ecf7daa3d5be704d9ac311fbbecf9f9f5b8b1c75beff894e4cf0d8fda4d6ff728a638dedf77aff0197179  main.conf
 "
diff --git a/community/iwd/ead.confd b/community/iwd/ead.confd
index f2d7c8a4c674d7c9c68e97df30b999cf30e46670..8ccfd63037d23537cd6a056d80c5a5a6ac0d6592 100644
--- a/community/iwd/ead.confd
+++ b/community/iwd/ead.confd
@@ -12,7 +12,7 @@
 #command_args=
 
 # Log messages are redirected to syslog. Set to empty string to disable.
-#error_logger="logger -t ead -p daemon.info"
+#error_logger="logger -t ead -p daemon.info >/dev/null 2>&1"
 
 # Uncomment to use process supervisor.
-#supervisor="supervise-daemon"
+# supervisor="supervise-daemon"
diff --git a/community/iwd/ead.initd b/community/iwd/ead.initd
index c16cc5140a1c286d140dc0d7888dea4ddfbaf358..4abe87778e645cf03dd1ce3961440baa0913af50 100644
--- a/community/iwd/ead.initd
+++ b/community/iwd/ead.initd
@@ -2,7 +2,7 @@
 
 description="Ethernet authentication daemon"
 
-: ${error_logger="logger -t ead -p daemon.info"}
+: ${error_logger="logger -t ead -p daemon.info >/dev/null 2>&1"}
 
 command="/usr/libexec/ead"
 command_background="yes"
diff --git a/community/iwd/iwd.confd b/community/iwd/iwd.confd
index 9fed1e0a1c5f0b8a2fd15e22eabc4f2635cfa947..347008816d480d37d5d05e0692bffe428b5697c6 100644
--- a/community/iwd/iwd.confd
+++ b/community/iwd/iwd.confd
@@ -12,7 +12,7 @@
 #command_args=
 
 # Log messages are redirected to syslog. Set to empty string to disable.
-#error_logger="logger -t iwd -p daemon.info"
+#error_logger="logger -t iwd -p daemon.info >/dev/null 2>&1"
 
 # Number of milliseconds to wait after starting and check that daemon is
 # still running. Set to empty string to disable.
@@ -21,4 +21,4 @@
 #start_wait=50
 
 # Uncomment to use process supervisor.
-#supervisor="supervise-daemon"
+# supervisor="supervise-daemon"
diff --git a/community/iwd/iwd.initd b/community/iwd/iwd.initd
index df5cfb5d72ab08fee390dffc2fa43862194e5bbd..62e25cf819a8f991daef4fe665266dac9ea7a164 100644
--- a/community/iwd/iwd.initd
+++ b/community/iwd/iwd.initd
@@ -2,7 +2,7 @@
 
 description="iNet wireless daemon"
 
-: ${error_logger="logger -t iwd -p daemon.info"}
+: ${error_logger="logger -t iwd -p daemon.info >/dev/null 2>&1"}
 : ${start_wait=50}  # milliseconds
 
 command="/usr/libexec/iwd"