diff --git a/testing/libsurvive/APKBUILD b/testing/libsurvive/APKBUILD
index 4b01b37bcb362c40e29ebce0f97cce177d2c71a3..a669079a6f9c4908f80a744dfffcbe4d4e4ffc41 100644
--- a/testing/libsurvive/APKBUILD
+++ b/testing/libsurvive/APKBUILD
@@ -1,9 +1,8 @@
 # Contributor: Bart Ribbers <bribbers@disroot.org>
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=libsurvive
-pkgver=0.2_git20201012
+pkgver=0.3
 pkgrel=0
-_commit="e5683f23165e9bcf851f817fae170843ffc76a5b"
 pkgdesc="Open Source Lighthouse Tracking System"
 url="https://github.com/cntools/libsurvive"
 arch="all"
@@ -23,9 +22,8 @@ makedepends="$depends_dev
 	cmake
 	"
 subpackages="$pkgname-static $pkgname-dev $pkgname-bash-completion"
-source="https://github.com/cntools/libsurvive/archive/$_commit/libsurvive-$_commit.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cntools/libsurvive/archive/v$pkgver.tar.gz"
 options="!check" # Requires live test data
-builddir="$srcdir/$pkgname-$_commit"
 
 build() {
 	cmake -B build \
@@ -45,4 +43,4 @@ package() {
 	cp -r tools/viz "$pkgdir"/usr/share/webapps/survive-viz
 }
 
-sha512sums="e7c69f6046a8207217aa3b3c94e95190360257d8b52706ecc3758189a88d95c7dd0afb92938a0fb71e6f7031dc44e3a043627ff2a2365d385d26dd12d25e6f79  libsurvive-e5683f23165e9bcf851f817fae170843ffc76a5b.tar.gz"
+sha512sums="2aa87ae76993cf92c516786f86a61e249e3bc87a8f44c167440cdfc453af0c10f25dd2ede31b5a14f1950e944a3baa8f7cb81c159f6edbf6471e8542991b98d8  libsurvive-0.3.tar.gz"