diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index 88b78844df358153eb733b2baae818832eb9cd08..bd7065e7dd52b79443192517b2fc911d09d2c86c 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -88,7 +88,7 @@ pkgname=nodejs
 # Note: Update only to even-numbered versions (e.g. 6.y.z, 8.y.z)!
 # Odd-numbered versions are supported only for 9 months by upstream.
 pkgver=16.15.0
-pkgrel=0
+pkgrel=1
 pkgdesc="JavaScript runtime built on V8 engine - LTS version"
 url="https://nodejs.org/"
 arch="all !riscv64" # hangs indefinitely on builders
@@ -150,9 +150,6 @@ build() {
 	# its own release cycle and version numbering, so it's better to keep
 	# it in a standalone aport.
 	#
-	# TODO: After icu package is modified to split data into multiple
-	# variants, change --with-intl to "system-icu".
-	#
 	# TODO: Fix and enable corepack.
 	python3 configure.py --prefix=/usr \
 		--shared-brotli \
@@ -163,7 +160,7 @@ build() {
 		--ninja \
 		--openssl-use-def-ca-store \
 		--with-icu-default-data-dir=$(icu-config --icudatadir) \
-		--with-intl=small-icu \
+		--with-intl=system-icu \
 		--without-corepack \
 		--without-npm