diff --git a/testing/libfyaml/APKBUILD b/testing/libfyaml/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..462449e1c2131c6de65b216d7b335ff8fb10fd3b
--- /dev/null
+++ b/testing/libfyaml/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=libfyaml
+pkgver=0.5.7
+pkgrel=0
+pkgdesc="Fully feature complete YAML parser and emitter"
+url="https://github.com/pantoniou/libfyaml"
+arch="all"
+license="MIT"
+depends="libltdl"
+checkdepends="check git"
+makedepends="autoconf automake bash libtool"
+subpackages="$pkgname-dev"
+source="https://github.com/pantoniou/libfyaml/releases/download/v$pkgver/libfyaml-$pkgver.tar.gz"
+options="!check" # tests failing, (See: https://github.com/pantoniou/libfyaml/issues/20)
+
+prepare() {
+	default_prepare
+	./bootstrap.sh
+}
+
+build() {
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--libdir=/usr/lib \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--disable-static
+	make
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+check() {
+	make check
+}
+
+sha512sums="ccdd47cdc1703d18a3aee362b3acbc6a3f98fbb65032544231a05eb944a8d9a6e160b6411a2db0f50e4f70f44e4aa368f1df15a7980ce5480be59dd99e9c58b8  libfyaml-0.5.7.tar.gz"