diff --git a/community/pil-squasher/0001-Install-pil-splitter-during-make-install.patch b/community/pil-squasher/0001-Install-pil-splitter-during-make-install.patch
new file mode 100644
index 0000000000000000000000000000000000000000..a76656e6889efa0efa0577c5a9c49de65daabaa7
--- /dev/null
+++ b/community/pil-squasher/0001-Install-pil-splitter-during-make-install.patch
@@ -0,0 +1,26 @@
+From 0a001a728d1fe844258b006cf298e69cbdcf9b2e Mon Sep 17 00:00:00 2001
+From: Luca Weiss <luca@z3ntu.xyz>
+Date: Tue, 24 Oct 2023 21:09:54 +0200
+Subject: [PATCH] Install pil-splitter during 'make install'
+
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index b047c49..f32b982 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,8 @@ all: $(OUT)
+ 	$(CC) $(LDFLAGS) -o $@ $^
+ 
+ install: $(OUT)
+-	install -D -m 755 $< $(DESTDIR)$(prefix)/bin/$<
++	install -D -m 755 pil-squasher $(DESTDIR)$(prefix)/bin/pil-squasher
++	install -D -m 755 pil-splitter $(DESTDIR)$(prefix)/bin/pil-splitter
+ 
+ clean:
+ 	rm -f $(OUT) $(OBJS)
+-- 
+2.42.0
+
diff --git a/community/pil-squasher/APKBUILD b/community/pil-squasher/APKBUILD
index 0175e661ade41609d5a5be1ec79305d05049425c..b233bab02096e26c320ffcf2e46ba1178cc0a318 100644
--- a/community/pil-squasher/APKBUILD
+++ b/community/pil-squasher/APKBUILD
@@ -1,13 +1,14 @@
 # Maintainer: Luca Weiss <luca@z3ntu.xyz>
 pkgname=pil-squasher
-pkgver=0_git20210529
+pkgver=0_git20230828
 pkgrel=0
-_commit="843950ff8445cb02ee543ec751ab42112d39a8e0"
+_commit="509cf42bdd15bc4b08de3d1e7ba093d3f27464e1"
 pkgdesc="Convert split .mdt + .bXX files into a .mbn file"
 url="https://github.com/andersson/pil-squasher"
 arch="all"
 license="BSD-3-Clause"
-source="$pkgname-$_commit.tar.gz::https://github.com/andersson/pil-squasher/archive/$_commit.tar.gz"
+source="$pkgname-$_commit.tar.gz::https://github.com/andersson/pil-squasher/archive/$_commit.tar.gz
+	0001-Install-pil-splitter-during-make-install.patch"
 builddir="$srcdir/$pkgname-$_commit"
 options="!check" # No tests
 
@@ -20,5 +21,6 @@ package() {
 }
 
 sha512sums="
-8d68ffc31fc51e9b16a2575404f13335ab4e2203cfec867c972c1714d066e52f846293b97907abed857ed73bab44ae59eade5fb0d1d058f20a47810319a19d5d  pil-squasher-843950ff8445cb02ee543ec751ab42112d39a8e0.tar.gz
+44c713e71c95c914ed990a6d5afaa625dd1cb1b8561568f43698e00afbd46d460cc722e882b6ee4ab7f9e364335cd93eb02db53445e242c91735d9e731068bc6  pil-squasher-509cf42bdd15bc4b08de3d1e7ba093d3f27464e1.tar.gz
+abc53fc70176a0d2fac9983d761a5f046352a7f957b2e60c9893df3580e882b55c831faa8505362264ecbeb4850989c9916e6e1340d6ce725f531b8c15508e02  0001-Install-pil-splitter-during-make-install.patch
 "